Autofill Refuses to be Enabled - Well, Sort Of


With the recent Dropbox free account unpleasantness, I decided to reevaluate my need for a vault shared among my devices via Dropbox (the way I always used to do it) while all my other vaults were shared among my devices via (new new way I do most of it). I decided that I don't really need the Dropbox sharing, especially if I can't actually do it any more without another $100/year of cost. So I decided to move everything from the vault shared via Dropbox to appropriate vaults shared via And now my vault on Dropbox is empty (except for items in Trash).

What I Tried

On on of my Android devices, I went into the phone's settings for 1Password, forced stop, cleared cache, and cleared data. Launching 1Password again, I saw the expected new user choices. This time, instead of starting with Dropbox and then adding my account, I went directly to sign in with I'm sitting at my Mac, so had 1Password there put up the QR code, and scanned it on my Android device (Pixel 2 XL running Android P / 9).

Side Problem(s)

BTW, when I held the phone vertically, the QR code looked stretched into a rectangle. When I held the phone horizontally, it still looked stretched, but 1Password recognized the QR code. Pretty strange, since I haven't seen any such stretching when just using the camera to take photos. And then, after scan but before entering the master password, rotating back to vertical completely exits the account adding. The master password has to be entered while the phone is still held horizontally.

The Problem

Completing the sign-in process successfully, I enabled the fingerprint reader and "Accessibility", but the "Autofill" setting refused to be turned on. Continuing, I verified that my logins (etc.) were showing up correctly, and then went back into Settings | Filling. Saw "Accessibility" still turned on. Turned on "Auto-copy one-time passwords", and again tried and failed to turn on "Autofill"

The Resolution?

So, just for grins, and because I used to use Windows all the time, I rebooted the phone. Going back into 1Password | Settings | Filling, I see that "Autofill" is turned on. So, yay?

1Password Version: 7.1.4.BETA-2
Extension Version: Not Provided
OS Version: Android 9
Sync Type: 1Password for Families
Referrer: forum-search:Autofill Refuses to be Enabled


  • mverdemverde

    Team Member

    Thanks for the detailed report @RonHeiby!

    I have to confess that I'm almost more curious about the side problems that you mentioned than the main problem. Let's start with the main problem though. When you say that the Autofill setting refused to be turned on, do you mean that it refused in 1Password? Or that it refused in the Settings app where you would select 1Password as your Autofill provider?

    I haven't been able to reproduce the issue on my end, so it leaves me wondering if the system was perhaps in a bad state and restarting fixed that. Would you be up for repeating the steps that you followed to see if it is reproducible again?

    For the side issues, we are aware of an issue with stretching the camera image for the QR code scanner. What's strange to me though is that you mentioned that you were able to rotate it horizontally on your phone. While we do allow rotation of that interface on tablets, we restrict the orientation to portrait mode on phones. This determination is made entirely based on screen size and screen density though. Could you tell me which device you were using when you encountered the problem with exiting the account adding? I'd like to reproduce that issue on my end and file it as a bug. ;)

  • Really sorry I didn't notice the response before now, when my memory is hazy with the passage of time.

    I believe that it was 1Password refused to let me enable Autofill within the 1Password app. But since this Spring, I've installed 1Password onto at least four Android phones and did not experience this (or any real) problem. And, since even in this case the problem went away after the phone re-booted, I think we're reasonably safe calling in non-reproducible and some weird fluke.

    Based on the date of this thread and the phone I would have just received around that time, I'm going to say that it was a Beta release Samsung Fold. And that fits well with your statement about tablets and just basing it on screen size / density, because the big selling point on the Fold is the larger screen real estate.

  • periperi

    Team Member

    Thanks for the update, @RonHeiby. I'm glad to hear that it seems to have been just a weird fluke.

    Let us know if you need anything else!

This discussion has been closed.