Op signin not working on Git Bash for Windows

Community Member
edited February 2020 in CLI

I wonder if anyone has been experiencing issues using 1password CLI from Git Bash.
the op --version command works fine (it returns 0.8.0), but the op signin my-team my-username asks for the master key and then gets stuck (hangs) , without asking for password. Yes, I tried different times to be sure the master key was correct. Yes, I run Git Bash as Administrator.
Same signin works fine in Powershell.
However, for development process purpose, I need to work in Git Bash.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • felix_1p
    1Password Alumni
    edited February 2020

    Thank you for the report and sorry for the late response. I'm not a Windows user myself but I will try to replicate it.

  • forty2
    Community Member

    I know I'm dredging up an old thread, but I wanted to add that this is the experience I get on one of my computers no matter what shell I use (I've tried Powershell, CMD, and git-bash). The signin command simply never prints a prompt for the password. This has been happening across many different version updates, but only on one computer. Others seem to work fine.

    However (and this is why I wanted to chime in), not long after I first encountered the issue, on a whim I tried just typing in my password anyway. Much to my surprise, it worked! So, although it appeared to be a hang, it actually was just failing to print the prompt text. The actual sign-in worked fine. I don't know if that's what's happening in your situation but it may be worth a try.

  • Hey @forty2

    We were able to reproduce that issue and have a bug filed for it. Thanks for taking the time to chime in with the additional information. I've added your notes to the bug report. Hopefully we can get that fixed up soon.


    ref: dev/b5/op#752

This discussion has been closed.