Search field stops working during sync in iOS extension

This has been a bug I’ve encountered in the iOS extension for a long time.

Steps to reproduce:

  1. Open 1Password extension in Safari or any other app.
  2. I start searching for the login I want.
  3. Search results start to filter down but then the list of logins appears to refresh and displays the same results as when the input is blank, not filtered by the search input.
  4. Typing additional characters, such as if the input said “App” and I type “Apple” doesn’t filter the search results.

The only thing I can do is clear the input and then type my search again.


1Password Version: 7.6.2
Extension Version: Not Provided
OS Version: iOS 13.6.1
Sync Type: 1Password
Referrer: forum-search:Search field stops working during sync in iOS extension

Comments

  • BenBen AWS Team

    Team Member

    Hi @alextan

    Thank you for the report. Is this happening with the share sheet extension, or with Password AutoFill? I tested against the share sheet extension and was not able to reproduce the issue using the steps you provided. Does the issue happen consistently for you, or only on occasion? If only on occasion... any indication of what that occasion is?

    Thanks!

    Ben

  • It's with the Password AutoFill extension. There's no specific time that I can think of that triggers it but like I said my hunch is that syncing of some sort is occurring to replace the database so perhaps after another device adds a login and you haven't synced on the device you're using.

  • BenBen AWS Team

    Team Member

    Thanks @alextan; we appreciate the report. I'll keep an eye out for that behavior. If I find a way to reproduce it I will file an issue with our development team. In the meantime, if you spot anything that allows you to reproduce the issue consistently, please let us know.

    Ben

  • FWIW I see this semi-frequently as well (latest iPadOS) but in my case it's only when it's a basic auth dialog in Safari, not an actual regular website form.

  • ag_anaag_ana

    Team Member

    @VirtualWolf:

    And is this happening every time you see a basic auth dialog in Safari?

  • No, it's not that easy to reproduce unfortunately, but it is the only time I ever see this behaviour. I just tried five times in a row in a new private window in Safari and couldn't get it to happen. :(

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation @VirtualWolf. I have also tried testing this in Safari and I have not been able to reproduce it so far. I will keep testing a little bit more, but we will definitely keep an eye out in case we get other reports :+1:

  • MrCMrC Community Moderator

    I've reported this previously too, in another thread. It occurs probably once a day or so (and that's likely due to my infrequency of use of the autofill on my iPad of late). The only way to resolve it is to dismiss the dialog, and re-try the autofill. I see it routinely during a login for a game where I have two accounts and swap between the two.

  • BenBen AWS Team

    Team Member

    Thanks folks. We're still trying to nail down steps to reproduce this, so if you notice there are actions you take or circumstances that exist that cause this to happen please let us know.

    Ben

  • I have a video of the bug in action if you'd like to see it that I could PM (contains email addresses so don't want to post it here). It occurred while using basic auth.

  • BenBen AWS Team

    Team Member

    Hi @alextan

    Does the problem occur every time you take the actions in the video? Please email it to [email protected] and include a link to this thread for context (https://1password.community/discussion/comment/574210/#Comment_574210).

    Thanks!

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file