Cannot sign in when master password contains a double-quote character

xverxver
edited September 2020 in Linux Beta

Hi,

I just tried to give the Linux preview a shot. Unfortunately, I found that after the web sign-in thingy, where it then asks for my master password in the native application, a generic "Cannot sign in" error message would immediately appear.

Next I tried entering an intentionally wrong master password and found that a spinner would appear and it took a second or two to return an error. I narrowed it down to the doublequote (") character in my password. After changing my master password to no longer contain a ", the sign-in worked normally.

Expected behavior is that any character works as master password.

Cheers,

xver


1Password Version: 0.8.4 @0e67d21
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @xver,

    Thanks for taking the time to report this. I was able to reproduce the issue with the " character and have filed a report to investigate it, we'll get it fixed.

    ref: dev/core/core#2760

  • Hey @MikeT,

    I'm seeing this bug with U+0020 (space character) as well. After removing U+0020 from my password, I was able to log in as expected.

    I reproduced this in the Debian package as well as the Arch source distribution

    version

    $ sudo apt search "1password"                                                                                                                                
    Sorting... Done
    Full Text Search... Done
    1password/edge,now 0.9.10-5-42790 amd64 [installed]
    

    Smol doc note as well. Anyone behind a NAT will probably experience issues with receiving keys from the naked domain in https://support.1password.com/getting-started-linux/

    $ sudo apt-key --keyring /usr/share/keyrings/1password.gpg adv --keyserver keyserver.ubuntu.com --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
    [sudo] password for leigh: 
    Executing: /tmp/apt-key-gpghome.pJY3G834Th/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
    gpg: keyserver receive failed: Server indicated a failure
    

    I don't think specifying the protocol and port will cause any harm here, but I'll leave that to you!

    $ sudo apt-key --keyring /usr/share/keyrings/1password.gpg adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
    Executing: /tmp/apt-key-gpghome.8O9pgpyXbK/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
    gpg: key AC2D62742012EA22: public key "Code signing for 1Password <[email protected]>" imported
    gpg: Total number processed: 1
    gpg:               imported: 1
    
  • BlakeBlake

    Team Member

    Hi @grepLeigh 👋

    Can you try updating to 0.9.11-3 and try reproducing this one again? I was able to sign-in successfully while using U+0020 in my Master Password successfully in my own Debian environment using the latest available version.

    Update 1Password for Linux

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file