libuuid not provided on OpenSUSE

Installing 1Password for Linux is still a bit rough on OpenSUSE. 1Password needs libuuid, which cannot be provided on OpenSUSE, because that package is provided throught libuuid1. Ignoring the installation problem seems to be fine for now, because I already have libuuid1 installed on my system.


1Password Version: 0.8.10
Extension Version: Not Provided
OS Version: OpenSUSE Tumbleweed
Sync Type: Not Provided

Comments

  • SavanniSavanni

    Team Member

    Hi, @tdegroot96 . Thanks for letting us know.

    I was not able to get to this last week, but I've made myself an OpenSUSE machine and will see about figuring it out. I'm much more familiar with the Debian side of the world, so I will need to do some work to familiarize myself.

  • The spec file lets you specify files instead of package names, meaning the spec could have Requires: libuuid.so.1 instead of the package name. (Or you can likely do this in fpm or other generation tools as well) That's could be one option to solve this.

    https://docs.fedoraproject.org/en-US/packaging-guidelines/#_file_and_directory_dependencies

    Happy to help test or answer any questions about rpm/spec.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file