1password for linux.beta does not obey settings.json

My 1password linux client (GUI version) keeps locking up and my settings are ignored:

{
  "$schema": "https://onepassword.s3.amazonaws.com/schema/settings.json",
  "security.autolock.minutes": "9000",
  "security.autolock.onWindowClose": "false",
  "security.autolock.onDeviceLock": "false",
  "security.clipboard.clearAfter": 120
}

I have two 1password accounts connected to the client. What is wrong?


1Password Version: 0.9.4-1-32510
Extension Version: Not Provided
OS Version: Ubuntu 20.0.4
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @astronom,

    Thanks for reporting this.

    When you said locking up, do you mean freezing or just auto-locking too early for you?

  • No, just auto-locking too early. I have two accounts configured. I have to unlock it very often which is inconvenient.

  • MikeTMikeT Agile Samurai

    Team Member

    @astronom, is there any pattern to when it starts to auto-lock, does it seem to happen after certain inactivity period of time or whenever you sleep/wake the computer, turn on screensaver or anything like that?

    You're using Gnome on Ubuntu 20.04, right?

  • Yes, I'm using Ubuntu 20.04 with Gnome. The locking happens while the PC is running when I'm not using the 1password gui for to long. Session lock and screen saver are turned off and the computer never suspends and I'm quite busy working on projects. When I start 1password, there is a small icon in the task bar indicating the process is there and running. When I close the window, I can open it again using the small icon (the icon has three options: Open 1password, Lock and Quit). No password required.

    But when I do not use it for too long, the window apparently closes itself or locks (I never have seen it closing - it is usually minimized or behind some other window). The small icon, however, is still there. When I chose 'open 1password' from the small icon, it opens locked and asks for my password. It could be, that the process for the actual 1password ends, while the process for the applet (small icon) keeps running.

  • MikeTMikeT Agile Samurai

    Team Member

    @astronom, I just copied your settings into mine and the app said it is invalid in the logs. I just reviewed it and I know why, you've encoded "" for the settings that are not needed, they're actually numeric and boolean values with no quotes at all.

    Here's the settings for you to copy/paste into your setting file. We do plan to add a settings UI to validate these settings on the fly.

    {
        "$schema": "https://onepassword.s3.amazonaws.com/schema/settings.json",
        "security.autolock.minutes": 9000,
        "security.autolock.onDeviceLock": false,
        "security.autolock.onWindowClose": false,
        "security.clipboard.clearAfter":120
    }
    

    Let me know if this helps.

  • Thanks Mike, I will test a few days to see if it works and report the result here. Great to hear, that the settings UI will come.

  • MikeTMikeT Agile Samurai

    Team Member

    You're welcome and let me know how it turns out.

  • @MikeT 1pass was running since this morning and never locked itself. Thanks for your help ;-)

  • BenBen AWS Team

    Team Member

    Glad to hear Mike was able to help! :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file