I keep getting asked for 2fa (Snap store needs to grant additional permission to 1Password)

brettnbrettn
edited December 2020 in Linux Beta

Hi there :)

Every time I open the app, I keep getting asked for the 2-factor authentication code. It is very frustrating! Apart from that, the app is working fine. I am using the snap and Ubuntu 20.10. Thanks to 1password for developing this.

Cheers


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • OK. The app has updated to the new beta release, and, I am still experiencing this issue...

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @brettn,

    Thanks for writing in.

    As you are using the snap version of 1Password, you may need to give 1Password additional permissions in the software/snap store to give it access to your keyring, so that it can store 2FA token in there.

    Here's how to check and/or grant permission: https://1password.community/discussion/115935/1password-for-linux-2fa-faq

  • Thank you. This solved my issue :)

  • Had the same issue, thanks for the FAQ entry.

    IMO it would be nice if 1PW would tell me that this is the issue and how to resolve it. Similar to how permission problems are solved when using macOS.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    brettn, you're welcome!

    @mix, thanks for the great suggestion! I believe we already do plan to do just that, we don't have the infrastructure just yet implemented to make the app more proactive with informing the users on what the issue is. You can expect us to improve us continuously over time.

  • MikeTMikeT Agile Samurai

    Team Member

    By the way, we plan to work with the snap store to allow 1Password to be granted this permission by default. We'll share more details about this as soon as we can.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file