settings.json opens in text editor instead of app or browser

Hello there!

I'm running the beta in Debian 10 and when I try to go to the settings so I can choose to automatically remember logins, instead of getting to a settings page, the json file opens in Visual Code. Is there a way to get to the settings?

Thanks for your time!

1Password Version: 0.9.7-34739
Extension Version: 1.22.3
OS Version: Debian 10
Sync Type: Not Provided


  • Seeing as it opens Firefox for me, I imagine it's currently unimplemented and only opens that json file in the default program for that filetype.

    $ xdg-mime query default application/json

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Thanks for writing in!

    @schwim, zorael pretty much got it. We currently do not have a Settings UI for the 1Password for Linux app just yet and what it does now is open up our settings.json file with the default editor set for the JSON file extension.

    It is expected that your Visual Code opens it for you. It should be able to auto-complete settings for too; add a comma to the end of the first setting you see and then press enter to add a new line. Start with " and it should give you a list of settings like so:

  • edited January 7

    @MikeT .. Which VS Code extension have you installed to get the autocompletion?

    Sorry - double post. Accidentally saved another draft. No idea how to delete a post .. :-(

  • Dayton_agDayton_ag

    Team Member
    edited January 7

    Hey @basuerito,

    Great question! The autocomplete you see in Mike's screenshot is actually made available by defining the $schema resource at the top of the page. You can define it in VS Code by pasting this into the top of your Settings.json:

    "$schema": "",

    Let me know if I can help with anything else! :smile:

    P.S. I cleaned up the initial post for you :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file