1Password for Linux Beta 0.9.10

SavanniSavanni

Team Member
edited February 1 in Linux Beta

Hello, and happy Tuesday! January, 2021 is already nearly over!

This week we have just a huge number of bug fixes. In this release, we fix some problems with device deauthorization, invalid date handling, responsiveness, and keyboard navigation. Additionally, KDE users are now able to use KWallet to store two-factor authentication tokens.

This week's list is long and exciting, so be sure to check out the release notes for the full list of details.

Navigation

The most visible changes you will be able to see this week lie in sidebar navigation.

Now the user menu will stay in place even as you scroll the sidebar:

Both the Vault and Tag sections are collapsible.

And finally, we have improved keyboard navigation in the sidebar. You are now able to use Tab to jump between sections and the up and down arrows to navigate amongst items within a section.

Navigation is tricky, and we are working hard to get it right for everyone.

Installing and upgrading

Go to the getting started guide for instructions on installing or updating 1Password.

As always, thank you so much for using 1Password and for all of the reports you send in that help us make our service better.

Comments

  • With current version on Ubuntu 20.10 I get the following error when upgrading:

    Preparing to unpack .../1password_0.9.10-5-42790_amd64.deb ...
    Unpacking 1password (0.9.10-5-42790) over (0.9.9-3-41483) ...
    dpkg: error processing archive /var/cache/apt/archives/1password_0.9.10-5-42790_amd64.deb (--unpack):
     error creating hard link './usr/share/polkit-1/actions/com.1password.1Password.policy': Invalid cross-device link
    Errors were encountered while processing:
     /var/cache/apt/archives/1password_0.9.10-5-42790_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    

    This is:

    OS: Ubuntu 20.10 x86_64 
    Host: OptiPlex 5080 
    Kernel: 5.8.0-41-generic 
    CPU: Intel i7-10700T (16) @ 4.500GHz 
    

    Any idea? Any previous installs went fine.

  • SavanniSavanni

    Team Member

    Hi, @basurerito . We have gotten at least one other report of this, so it appears that our new restricted policy files are causing problems with certain setups. Do you happen to be keeping /usr and /opt on separate partitions?

  • Hi @Savanni .. yes, I do:

    /dev/nvme0n1p1 vfat   2,0G     40M  1,9G    3% /boot/efi
    /dev/nvme0n1p2 ext4    57G     24G   30G   45% /
    /dev/nvme0n1p3 ext4    38G    7,2G   29G   21% /opt
    /dev/nvme0n1p4 ext4   373G    100G  255G   29% /home
    
  • SavanniSavanni

    Team Member

    Ah okay. We hard link the polkit file into place, and that obviously does not work across filesystems. I'll talk with the team to decide how we should fix this. In the mean time, you will probably have to skip this release. Many apologies.

  • @Savanni .. sure, no worries. Glad you pinpointed the issue :-) I'll be patiently waiting for a next release.

  • niceduckniceduck
    edited January 30

    Fedora 33 with separate /opt mount, install fails also ;

    Running transaction
    Preparing : 1/1
    Installing : 1password-0.9.10_5-42790.x86_64 1/1
    Error unpacking rpm package 1password-0.9.10_5-42790.x86_64
    Verifying : 1password-0.9.10_5-42790.x86_64 1/1

    Failed:
    1password-0.9.10_5-42790.x86_64

    Error: Transaction failed

  • SavanniSavanni

    Team Member

    Hi, @niceduck and @basurerito.

    I just put out 0.9.11, where I'm pretty sure we fixed the problem. Please let me know how it works out.

  • edited February 1

    @Savanni 0.9.11-3-44272 works like a charm on Ubuntu 20.10. Thanks :+1:

  • Dayton_agDayton_ag

    Team Member

    That's great, @basurerito! I'm glad to hear things are up and running again for you. Feel free to reach out with any further feedback! :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file