openSUSE Support and RPM error

The release notes for 0.9.3 indicate that 1Password should work for openSUSE, but I don't see any instructions for getting it set up. I assume that the AppImage and Snap are not what is meant, but I do not see any other instructions for setting up with openSUSE.

I added the Fedora repo and GPG manually through YaST and then attempted to install the package using zypper, only to get the following error:

Error: RPM failed: error: unpacking of archive failed on file /usr/share/polkit-1/actions/com.1password.1Password.policy;60124ff4: cpio: link failed - No such file or directory

/usr/share/polkit-1/actions/ exists on my system, and tinkering with the rpm indicates that it is probably trying to create a hardlink to /opt/1Password/com.1password.1Password.policy, which may not have been extracted yet. I'm not sure why a hardlink is being created when it would be fine to duplicate the file (or just not have it under /opt). The file should be replaced when the rpm gets updated, anyways.

To summarize:

  1. Release notes indicate support for openSUSE, but I cannot find instructions for doing so like with Ubuntu/Fedora/Arch.
  2. While trying the Fedora rpm repo, I ran into the above issue which seems like it could be solved by copying files instead of hardlinking them.

For (1), I'd be willing to help figure out the specific commands for setting up the repository from the command-line. I'd just like to know that the rpm will be usable first.


1Password Version: 0.9.10
Extension Version: Not Provided
OS Version: openSUSE Tumbleweed
Sync Type: Not Provided
Referrer: forum-search:opensuse repository

Comments

  • BlakeBlake

    Team Member

    Howdy @Shadow53 🤠

    We have received a couple reports of this so far, and it appears that our new restricted policy files are causing problems with certain setups.

    Currently, we hardlink the polkit file into place, and that obviously isn't working across filesystems, and resulting in failed installs.

    We're currently working to see how to best fix this, but in the mean time, you will probably have to skip this release. Sorry about that! 😞

  • SavanniSavanni

    Team Member

    Hi, @Shadow53. Blake said, several people ran into this last week. 0.9.11 just went live and should have this problem solved, as I switched to an after-install script that just copies the policy file into place. Please let me know how it goes for you.

  • felixoifelixoi
    edited February 1

    @Savanni I'm experiencing exactly this issue on ArchLinux AUR package with 0.9.11

    chmod: cannot access '/var/tmp/pamac-build-felix/1password-bin/pkg/1password-bin/usr/share/polkit-1/actions/com.1password.1Password.policy': No such file or directory

  • SavanniSavanni

    Team Member

    Hi, @felixoi . The AUR version of 0.9.11 isn't quite out yet. It lags a little bit behind the main release, and I only just approved it. You should be able to get it and try again in an hour.

  • Hey @Savanni . Thanks for your quick response. It's quite interesting as the package manager shows it for me.
    This error is during the installation of version 0.9.11. So I'm not sure if you are correct. Here is a full stracktrace: https://gist.github.com/felixoi/97802641c19b1abd2592ada0afc9e4c5

  • @Savanni @Blake I had told openSUSE to ignore the error and install the package anyway, so I am not sure if that affects this, but I just updated my system - including 1Password - and there were no issues during the update. So I think the change worked for me.

  • Seems like it was fixed tonight.

  • Dayton_agDayton_ag

    Team Member

    That's excellent! Thanks so much for sharing this feedback with us, it's very helpful. Feel free to reach out if we can do anything else to help out! :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file