openSUSE Leap 15.2 - GLIBC_2.27

Hi, wanted to install 1Password version 0.9.11 on OpenSUSE Leap 15.2 for the first time today. Installing as rpm from the official repo works fine. However, 1Password does not start. The following error is displayed on the console:

A JavaScript error occurred in the main process
Uncaught Exception:
Error: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by /opt/1Password/resources/app.asar.unpacked/index.node)

Officially OpenSUSE Leap only supports glibc in version 2.26. Can you adjust this?


1Password Version: 0.9.11
Extension Version: Not Provided
OS Version: OpenSUSE Leap 15.2
Sync Type: Not Provided

Comments

  • BlakeBlake

    Team Member

    Howdy @ChriMi_DE 🤠

    We have been trying to look into this as we actually haven't changed our glibc requirements at all, but we have updated some internal building processes as well as our libraries and frameworks. We haven't yet figured out why this was bumped to 2.27 just yet.

    We'll follow up as soon as we find out.

  • Thank you Blake :)

  • Dayton_agDayton_ag

    Team Member

    Hey there @ChriMi_DE, just wanted to pop in and let you know that we're still looking into this one. Once we have a bit more info, we'll update the thread. :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file