Bug in MRC Conversion Tool - Firefox and Wrong Timestamp [Solved]

AndreasW2AndreasW2
edited 12:20AM in Windows

Hi MRC

since I am new to all this I did not know what the best place was to post it, hope it is okay here.

First of all thank you for your conversion tool, it literally saved me hours today.

So I thought it is only fair that I can give back what I can: a bug report :blush:

I am running 85.0.2 (64-Bit) on Windows and used the latest version of your scripts to export/convert the Firefox Passwords to an 1PF file. However, the import on the most current 1Password 7 Desktop Version failed, because in the converted file, the timestamps where somehow wrongly formatted - they were a decimal, not a float, for example like this:

"updatedAt":1514482148.092

Obviously, the ".092" in the end failed the import.

When I ran the script with --no-timestamps, the import worked.

I hope this is reproducable and thanks again
Andreas


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • MrCMrC Community Moderator

    Hello @AndreasW2

    You're welcome, and thanks for the report.

    Can you tell me how you exported your Firefox passwords?

    Also, which version of Firefox are you running?

    I just tried it's native method to export as CSV but don't see floating point values for the time stamps, but rather integer stings.

  • Hi @MrC

    I am running Firefox 85.0.2 (64-Bit) on Windows and I exported it like in the readme, via "perl convert.pl -v firefox" - then I said yes to export my online profile, entered the master password, got confirmation of xxx imports and exports and that is that :)

    Thanks
    Andreas

  • MrCMrC Community Moderator
    edited February 21

    @AndreasW2 ,

    Ok. The reason I asked is that Firefox has changed its encryption scheme, and the native firefox converter no longer works. So I'm wondering why it worked for you. I'm guessing that the new scheme only takes affect for new profiles, or those who just start using saved passwords in Firefox, or who have not allowed Firefox to refresh (a newer feature in Firefox which updates a bunch of databases if Firefox has not been used in a while).

    So let's get onto the bug. When I wrote the script, timestamps were saved in milliseconds, and the converter divides by 1000 to resolve that. I wonder if that has changed. In the Converters\Firefox.pm file, at line 211, you'll see the code:

    $_->{$datekey} /= 1000;
    

    Can you try commenting that out, as:

    # $_->{$datekey} /= 1000;
    

    and re-running the converter, and check the dates?

  • MrCMrC Community Moderator

    @AndreasW2

    Just checking in with you to see if you need any more assistance.

  • @MrC sorry for the late reply, I was busy doing work stuff :)

    Yes, commenting out that line works like a charm - the dates are all right now.

    Thanks
    Andreas

  • MrCMrC Community Moderator

    Cheers, thanks for the update @AndreasW2 .

    Enjoy 1Password!

  • Dayton_agDayton_ag

    Team Member

    Thanks for all your help, @MrC! :smile::+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file