Debian Bullseye

Trying to install but getting libappindicator1 error. anyway around this?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Dayton_agDayton_ag

    Team Member

    Hey there @pitt1717, great question! You should be able to resolve this dependency by installing libappindicator1 directly - if you're running a debian-based distro, you can do so using the following command in Terminal:

    sudo apt install libappindicator1

    With that resolved, could you try installing 1Password again, and let me know how it goes? Thanks! :smile:

    Get the 1Password for Linux beta

  • Hey I should have mentioned. The error included a message that libindicator1 is depreciated. Not sure what this all means but I’m sure any other software which needs it will face install issues. may need to remove it as a dependency???

  • Dayton_agDayton_ag

    Team Member

    @pitt1717:

    I'll make sure to pass this along to the Development team. Thanks so much for bringing this to our attention! :smile:

  • SavanniSavanni

    Team Member

    Thank you for mentioning this, @pitt1717 . At minimum, I can try to make this install automatically in the next release. However, like you said, it's being removed entirely from Debian, and possibly other repositories as well, so I know now that we will need to adapt to that.

  • so i posed the question of the road map for debian in their forums, Looks like the distro will be moving to Ayatana (libayatana-appindicator). hoping that you guys can look into this for future builds.

    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895037
    https://lists.debian.org/debian-devel/2018/03/msg00506.html
    https://wiki.debian.org/Ayatana/IndicatorsTransition

    love your app and been using it since 3.5 (mac). recently switch over to linux and went to the sub model just for linux support.

  • Dayton_agDayton_ag

    Team Member

    @pitt1717 Thanks so much for grabbing those links for us, and for the feedback! We're thrilled that we get to bring some 1Password goodness to Linux. :smile: Let us know if we can help out with anything else. :smile:

  • I'm also running into the same issue with Debian bullseye. Will this be fixed by the time Bullseye is the new stable version?

  • Dayton_agDayton_ag

    Team Member

    @dajonker:

    I can't comment on timelines for specific changes, but it's definitely on the Team's radar to address. :chuffed::+1:

    ref: /dev/core/core/#5403

  • Awesome, thank you!

  • Dayton_agDayton_ag

    Team Member

    @dajonker: Not a problem! :smile::+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file