Cannot Access RPM Repo: Permission Denied

I'm not sure when this started, but when I run zypper refresh on OpenSUSE, I am unable to download the metadata for the repository with the following error:

Permission to access 'https://downloads.1password.com/linux/rpm/media.1/media' denied

I tried manually access that URL in the browser, as well as every parent directory up to the root (sub)domain, and all gave me Access Denied.

I'm not sure if it's relevant, but it looks like all the other platforms are unaffected because 1Password is listed on their appropriate marketplace or, in the case of Windows/Mac, the downloads are hosted on https://app-updates.agilebits.com/ instead.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: OpenSUSE Tumbleweed
Sync Type: Not Provided

Comments

  • lumarellumarel
    edited March 26

    If I'm allowed to contribute here :)

    I tested it out of my curiosity, and I can confirm that these files are not there. (and was first a little bit confused because I thought that zypper also uses the repomd.xml file like yum/dnf, which is there)
    And furthermore, filebrowsing is disabled on the repostructure, for the good or not good, it isn't really necessary :+1:

    If you look at the installation documentation you might notice, that openSUSE is not supported through it's package manager up to now (ref), you might want to try to install 1Password via the SnapStore or the AppImage :chuffed:

  • Dayton_agDayton_ag

    Team Member

    @Shadow53

    The last reply was bang-on (thanks @lumarel!) - that file does not exist and we do not permit navigation of the directory via the browser. We also currently do not have zypper support for installing 1Password, and recommend using the SnapStore or AppImage to get 1Password running on OpenSUSE.

  • What is odd though is that it worked previously -- I have a now-outdated installation of 1Password from that same repository.

    I would use Flatpak if that were available, since that is a fairly distro-agnostic method of distribution. Snaps are still more of an ubuntuism for me, and AppImages aren't easily updated with a script.

    Is there a way I can request/help implement 1Password support for zypper/openSUSE or Flatpak? Either one would be a suitable solution for me.

  • Dayton_agDayton_ag

    Team Member

    @Shadow53

    We do not have plans for supporting Zypper at this time, but there is an internal discussion about bringing Flatpak support at a later date.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file