1password auto-locks instantly

PedroidPedroid
edited March 29 in Linux Beta

I have been running 1password beta on Arch linux for a few months now without incident - although I was unaware of the browser integration being made available and haven't tried it yet.

I have a newer more annoying problem as of today and that's the desktop app is instantly auto-locking itself as soon as I unlock it. Basically I open the app, type my password and hit enter, the window closes and that somehow triggers the auto-lock. Console output:


1Password Version: 8.0.30
Extension Version: N/A
OS Version: archlinux 5.11.10
Sync Type: Not Provided

Comments

  • SavanniSavanni

    Team Member

    Hi, @Pedroid . Do you know when this error began?

    One suggestion I can make now is to check ~/.config/1Password/settings/settings.json. In there, check to ensure that "security.autolock.minutes" is not set to 0.

  • I update my system only once a week or so. The last time was this past Friday. So I believe it was after that.

    "security.autolock.minutes" was set to 0 but that's because the schema indicated this would be unlimited. Is that no longer the case?

  • Dayton_agDayton_ag

    Team Member

    @Pedroid There's been some internal changes to how these zero values are processed by 1Password, so it now reads 0 as immediately - sorry about the confusion! For now, we suggest setting security.autolock.minutes to a high integer to keep it awake as long as needed. :smile:

  • I've done that and it has fixed the problem. Although if I save the "Never" value in the UI for Settings it is recorded as a -1. If I leave that alone, what will that effectively be?

  • Dayton_agDayton_ag

    Team Member

    @Pedroid

    That should work! :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file