1Password for Linux, #33

SavanniSavanni

Team Member
edited April 6 in Linux Beta

Good evening, Linux users!

One might think that with last week's release going in the middle of the week, this one might be a little lean. Not so! We have another huge group of changes, along with a couple of improvements to significant features. Now, when you drag a file from your desktop onto a Document item, you'll see visual feedback to indicate where to drop the file. We have started adding command line options to 1Password to help with scripting. Further, we now have a quick and easy way to generate a diagnostic report that you can send to us when things are having troubles.

Check out our release notes for a full list.

The Command Line

Until today, we haven't had much in the way of a command line interface. However, as we learn more with using 1Password in various Linux environments, we're having brainstorms for ways to control 1Password from other applications.

So now, we have started experimenting with a command line interface. The commands so far are pretty simple, but same sometimes be useful. For instance, applications are unable to register keyboard shortcuts, such as the 1Password open/close shortcut, on Wayland. With the new --toggle flag on 1password, you are able to now create a shortcut in your system settings to quickly open and close 1Password.

We will continue to experiment with command line options and with our DBus interface as we discover more ways in which we can safely allow outside applications to send useful commands to 1Password.

Diagnostics

On occasion, some of you report problems with 1Password and we have to ask for diagnostic information. We now have one convenient button in the settings dialog that will generate a diagnostics file that you can then email to our support system.

We will save the report directly to your Desktop directory. This is a JSON file that you can inspect yourself, then send it through your favorite email client to [email protected].

Installing and upgrading

Go to the getting started guide for instructions on installing or updating 1Password.

Thank you for your patience, thank you for your feedback, and thank you for your support. We are always trying to make 1Password work better for more people, and we cannot do that without the feedback you have been giving us for the last six months.

Comments

  • Since upgrading, I am not able to open web pages as I was. When I select "Open and fill" on a website in 1P, I end up at fat URL that starts with https://1password.com/downloads/linux.

    1password 8.0.33-13.BETA

    I'm not expecting fill to work, but I do expect to get to the correct web page.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @johann_koebbe,

    Thanks for reporting this.

    Just to confirm, do you use 1Password in your browser and if yes, is it installed and it is not opening the right site?

    1Password is supposed to show this page when the browser integration is enabled and the extension isn't installed, so it can help you install the extension.

    However, we have a fix already for the next update where if you disabled the browser integration support, it switches from Open and Fill to Open on all website fields.

  • Is this release getting pushed to AUR soon?

  • edited April 7

    @MikeT Maybe a description of the lay of the land will help. In Firefox, I believe I am using what used to be called 1PX, but I guess it's now just called 1P/Browser. Because 1P/Linux didn't fill when opening, I sometimes use the desktop app to open the web page, and then use 1P/Browser to fill. 1P/Browser opens to the correct web page, but 1P/Linux does not, at least since this last update. I just checked and had Settings -> Autofill -> Share information with 1P in your Browser enabled. Disabling it did not produce different results, though. Closing and reopening 1P also did not help.

    I've been using 1P/Browser because I sync plugins across multiple platforms, and I want to be consistent in what I use. Is there a version of the Firefox plugin that I can install across Linux, Mac, and Windows that will open/fill correctly with all of the desktop apps?

  • Dayton_agDayton_ag

    Team Member

    @felixoi:

    This week's update won't be pushed to the AUR, but should be updated with next week's update when it is available.

    @johann_koebbe

    Thanks for that info! We suggest using 1Password in your browser across all of your devices, so it sounds like you've got things set up nicely from the browser perspective.

    I'm wondering if the browser integration is failing to make a connection between the desktop app and the browser, and that's what is causing the desktop app to fail to open the correct web address in your browser. Could you try opening the desktop app and signing in, confirm the browser integration is enabled in Settings, and then open up the browser - does 1Password in the browser unlock itself? If it does, can you switch back to the desktop app (while keeping the browser window open) and try to open a web page?

  • @Dayton_ag I should mention that I'm using 1P/Browswer 1.24.0. IIRC, that's not the one that has 1P/Linux integration. I followed your instructions, and (unsurprisingly) 1P/Browser did not auto unlock/open. Just for giggles, I tried opening a web page from 1P/Linux, and it went to the 1P website, not the site I wanted. I then unlocked 1P/Browser and tried again. Same result.

    I would like to reiterate that getting to the correct website from 1P/Linux did work prior to this update, I just had to fill with 1P/Browser.

  • Dayton_agDayton_ag

    Team Member

    @johann_koebbe

    Ah, I see, thanks so much for clarifying! Yes, 1Password 1.24.0 does not integrate with the 1Password Linux beta app, so this accounts for the issue you're seeing. There's been a change to 1Password's address-opening behavior in the current release, where 1Password will direct the user to our website to install the extension when integration is enabled but cannot be established with the extension.

    As Mike mentioned in their post above, there is a fix coming for this in the next update. :smile:

  • @Dayton_ag Same question I asked Mike, then:

    Is there a version of the Firefox plugin that I can install across Linux, Mac, and Windows that will open/fill correctly with all of the desktop apps?

  • Dayton_agDayton_ag

    Team Member
    edited April 8

    Ah my apologies, I misunderstood your question - yes, if you'd like to install the beta version of your current extension, you can enable browser integration with the Linux app, and this will not affect your current workflows on other devices (note that browser integration is not available for the Windows or Mac desktop apps at this time, so the beta version of 1Password in your browser will not change it's functionality on Mac or PC). You can find the beta version of 1Password in your browser here:

    Use 1Password Beta releases - Browser

  • Thanks @Dayton_ag . I installed version 1.25.1 and can open web pages again. Functionality on macOS with 1P7 appears to be unchanged. :)

  • Dayton_agDayton_ag

    Team Member

    @johann_koebbe:

    That's excellent! :smile::+1:

  • Excited for --toggle, when it comes into the AUR version. Thanks folks :chuffed:

  • Dayton_agDayton_ag

    Team Member

    @adamh Sounds good! There was some packaging issues with getting last week's update on the AUR, but we hope to have that resolved for this week's update - --toggle for everyone! :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file