Two application windows

Issue:
When triggering the 1Password app via the "1 Password Beta Firefox browser extension 1.25.2" I end up with two application windows.

Expected behavior:
When triggering the 1Password app via the "1Password Beta Firefox browser extension 1.25.2" I expect one out of two possible outcomes:

  • When the 1Password app is closed: open the 1Password app and focus the application window.
  • When the 1Password app is already open: focus the application window and focus the 1Password application window.

Steps:
1. Open browser
2. Go to a website with a login form.
3. Click the "Open 1Password" button or trigger 1Password via the defined shortcut (I added my preferred shortcut via the Settings app via 1password --toggle / not sure if this is of any relevancy)

System configuration:

  • 1Password: 1password 8.0.32-1 via AUR
  • Firefox: 87.0-1
  • 1Password Beta Firefox browser extension: 1.25.2
  • OS: Manjaro 21.0.1 Ornara
  • Kernel: x86_64 Linux 5.9.1-1-rt19-MANJARO
  • Resolution: 3840x2160
  • DE: GNOME 3.38.4
  • WM: Mutter
  • Disk: 171G / 1.8T (10%)
  • CPU: Intel Xeon W-3235 @ 24x 4.5GHz [36.0°C]
  • GPU: AMD POLARIS10 (DRM 3.39.0, 5.9.1-1-rt19-MANJARO, LLVM 11.1.0)
  • RAM: 4163MiB / 48133MiB

1Password Version: 8.0.32-1
Extension Version: 1.25.2
OS Version: Manjaro 21.0.1 Ornara
Sync Type: Not Provided

Comments

  • Dayton_agDayton_ag

    Team Member
    edited April 12

    Hey there @amadeusp81 , welcome to the 1Password Support Community! 🎉

    Thanks so much for writing in with this, I really appreciate it! It looks like you're running into a bug that our Development team has fixed in 0.9.33. This update didn't make it to the AUR due to some packaging issues, but this week's update, which should be released in the coming days, should resolve this. Could you keep an eye on our Releases page, grab this week's update when it becomes available, and let me know if the issue is resolved for you?

    ref: /dev/core/core/#6346

  • @Dayton_ag Thanks for your reply! Sure, I will let you know.

  • @Dayton_ag I am happy to report that the issues are gone with 0.9.33-26! :)

  • Dayton_agDayton_ag

    Team Member

    @amadeusp81 That's great, I'm glad to hear things are running smoothly for you now! :smile::+1: Let me know if I can do anything else to help out.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file