Enabling Browser Integration

SystemSystem

Team Member
This discussion was created from comments split from: 1Password for Linux, 8.0.33-26.

Comments

  • Hi, I don't really understand the browser integration. Which plugin do you need for it? The classic extension or the X? Because I don't get it working.

  • Dayton_agDayton_ag

    Team Member
    edited April 16

    Hey there @ThomasDB, I hope you don't mind that I split this off into its own thread. :smile: I can definitely help get this working for you! You'll need the beta version of 1Password in the browser, our modern extension - you can grab it from the link below:

    Use 1Password beta releases

    Update: With the release of 1Password in your browser version 1.24.1, the beta version is no longer required for browser integration.

    Once that's up and running, enable the browser integration in the desktop app:
    1. Launch the 1Password desktop app, and sign in.
    2. Click your account name in the top-left corner of the app, and click Settings.
    3. Switch to the Autofill heading, and ensure that Share information with 1Password in your browser is enabled.

    That should do it! Let me know how you get along, or if I can help with any of the steps. :smile:

  • That's okay It works now! Thanks for the help!

  • Dayton_agDayton_ag

    Team Member

    Any time! :smile:

  • I'm having a similar issue. I have installed and logged in to 1password-8.0.33_26.BETA-1.x86_64 on my fedora VM and it looks lovely. I found and checked the "share with browser" option. However, when installing 1p browser 1.24.1 in the VM's FireFox 86, the plugin directs me to a cloud login and doesn't seem to realise the linux desktop app is installed/running/unlocked. I tried logging it in, but afterwards it seems to have its own lock/timer settings and still doesn't recognise the desktop app.

    Do I have to log in to 1p browser? Leave it logged out? Neither seem to work for the use case of "start firefox, 1p can be used to fill items in browser right away because the desktop app is running and unlocked."

  • Dayton_agDayton_ag

    Team Member

    Hey there @j_son, I'm really sorry this isn't working for you!

    With the browser integration enabled in the desktop app and the browser extension installed, it should be able to connect - I gave this a test with Fedora and Firefox and things hooked up for me.

    Could you try closing out the browser and 1Password app completely and restarting your device? Once that is complete, pop open Firefox and head to a website to log into (email, Youtube, et cetera). Click the username field, and 1Password should prompt you to launch the desktop app, initiating the integration. Could you give that a shot and let me know how you get along?

  • @Dayton_ag Hi,

    I Have a problem with firefox 88.0b9, my extensions show that I have an update, but I'm the latest version of FF.

    The extension with google chrome works without problems in the same machine, I don't know if the issue is related to the version of FireFox

    Gustavo.

  • Hi Dayton, thanks. Am I supposed to only download the 1pX extension (now just called 1p) to firefox and not log in to it?

  • Dayton_agDayton_ag

    Team Member

    Hey there @woakas, I'm really sorry you're running into this issue with 1Password! This issue has to do with running the Firefox Developer edition. Our Development team is currently looking into this - I'll follow up with any information they provide. :smile:

  • Dayton_agDayton_ag

    Team Member

    @j_son
    Yep! Once the extension is installed (and provided that integration has been enabled in the desktop app), it should connect up right away, no need to sign into the extension itself. The desktop app and browser may need to be closed/re-opened, but integration generally starts up smoothly and reliably after that.

    If the app and extension aren't communicating, despite closing/re-opening the browser and desktop app, let me know and we can dig in a bit further. :smile:

  • I tried uninstalling and reinstalling the browser extension. Then I shut down the browser and the 1p app. I tried it a few times and only one time did the browser manage to start the 1p app, and I wasn't able to get the addon to recognise that the app was available at all.

    If it helps, when first installed (from addons.mozilla.org) the browser addon presents with a blank white page (setup screen?) upon startup. Further calls to it (via ctrl-period in a login box, etc) open a new tab and prompt me to log in.

  • If it helps, my privacy settings on this install of firefox are turned up pretty high, though they are the same as I had when actively using 1pX (on its own) and I didn't have any issues:
    Delete Cookies and Site Data when Firefox is Closed - enabled
    Use Custom Settings for History

    • Always use Private Browsing mode - disabled
    • Remember browsing and download history - enabled
    • Remember search and form history - disabled
    • Clear history when Firefox closes - enabled - clearing all but Browsing & Download History, Site Preferences.
  • Dayton_agDayton_ag

    Team Member

    Hey @j_son, thanks for sharing! Could you tell me how you installed 1Password - via the Snap Store/Ubuntu Software, or via Terminal?

  • Terminal, via the instructions on the download page (adding a repo, dnf install)

  • Dayton_agDayton_ag

    Team Member
    edited April 22

    @j_son:

    Hmm, that shouldn't be a problem - if installed from the Snap store it runs into some sandboxing issues, but that shouldn't be the case here. I'd like to dig in a bit more with some diagnostics information from your device - let's continue this conversation over email. Could you send me an email at [email protected], and include my name in the subject line?

    After you email in, you should receive a Conversation ID that looks like this: [#ABC-12345-678]. Please paste that here, and I'll use it to track your email down from my end.

    Thanks, I'm looking forward to getting this sorted for you! :smile:

    ref: QSQ-24848-622

  • Of course - I've sent you an email prefixed with your username. I haven't received an autoreply yet.

  • Dayton_agDayton_ag

    Team Member

    Thanks so much! I'll keep an eye out for your email and we can keep the ball rolling there. :smile:

  • @Dayton_ag Could you also update here on the problem from @j_son? I have the same issue. Already thank you! By the way, I use Firefox developer 89.0b2.

  • Dayton_agDayton_ag

    Team Member

    Hey there @ThomasDB and @woakas:

    Our team has looked into this and the reason that you're getting the error message in Firefox Developer may have to do with the permissions set for the browser - could you give the suggestions in the forum post below a shot, and let me know if that gets things working for you?

    1Password Support Community - 1p extension not working for Firefox Developer Edition 88.0b9 (64-bit)

  • ThomasDBThomasDB
    edited April 23

    Now Firefox doesn't want to start any more. :(
    Now I get the Mozilla-crashreporter.

  • Dayton_agDayton_ag

    Team Member
    edited April 23

    Hey @ThomasDB uh-oh, that's not good! Alright, let's get this back up and running. Could you try running this command again, but this time giving permission back to user? Something like this should do it:

    sudo chown -R $USER:$USER ~/.local/apps/firefox

    Could you give that a run, and let me know if that gets Firefox working again?

  • Sorry for the late response. Yes, now it works again for me.

  • Dayton_agDayton_ag

    Team Member

    @ThomasDB:

    That's excellent - sorry for the scare, there! To confirm, browser integration is still not yet working for you, correct? Are you still getting the Firefox has an update message?

  • ThomasDBThomasDB
    edited April 27

    @Dayton_ag Yes, unfortunately it still show it.

  • Dayton_agDayton_ag

    Team Member

    @ThomasDB Alright, thanks for that update. Let's continue this conversation over email. Could you send me an email at [email protected]?

    On your device, please open a terminal and run the command whereis firefox, and paste the output in your email.

    After you email in, you should receive a Conversation ID that looks like this: [#ABC-12345-678]. Please paste that here, and I'll use it to track your email down from my end.

    Thanks, I'm looking forward to getting this sorted for you! :smile:

This discussion has been closed.