Snap version needs removable-media plug?

I'm trying to access my Emergency Kit for first login, but I get a permission denied when trying to access my personal folders, which are located on an external drive. I tried 'snap connect 1password:removable-media' (which solved the same problem for other snaps) yet I got 'error: snap "1password" has no plug named "removable-media"'.


1Password Version: 8.0.33-26.BETA
Extension Version: Not Provided
OS Version: Ubuntu 21.04 and 20.10
Sync Type: Not Provided

Comments

  • Dayton_agDayton_ag

    Team Member

    Hi there @noemis, thanks for bringing this to our attention! I can't make any promises for future additions or changes to the app, but I've filed this feedback internally and passed it along to the capable hands of our Development team. :smile: In the meantime, the best solution would be to temporarily copy the file to the local drive, or type in the details from the Emergency Kit manually.

    Let me know if there's anything else I can do to help!

    ref: /dev/core/core/#6770

  • Dayton_agDayton_ag

    Team Member

    Hey @noemis!

    I just wanted to let you know that the option to connect to removable-media has been added to this week's release! Take it for a spin and let me know what you think. :smile:

  • Hi @Dayton_ag
    thanks for forwarding my issue to the development team! I tried it out today and it works perfectly, I can now use my Emergency Kit to sign in. Unfortunately it didn't solve the other (major) problem I'm having on both my Ubuntu 21.04 machines which is that 1Password won't ever launch again after initial sign in and reboot. Nothing happens at all if I click the icon or enter "1password" or "snap run 1password" in the terminal, it only works once right after (re)install, which I did several times. I had hoped this was related to the other problem, but it's probably something my end. I can add a new discussion for that if needed, though I will now try installing with apt.
    Thanks again!

  • Dayton_agDayton_ag

    Team Member

    @noemis

    I'm glad to hear that the plugin is working for you!

    1Password won't ever launch again after initial sign in and reboot.

    Hmm, that's definitely odd. I'm really sorry you're running into this issue - to get things back up and running, let's continue this conversation over email. Could you send me an email at [email protected], and include my name in the subject line?

    Before you send your email, could you zip up the 1Password logs - .config/1Password/logs - and attach it to the email? I'll dig in and see what I can find out.

    After you email in, you should receive a Conversation ID that looks like this: [#ABC-12345-678]. Please paste that here, and I'll use it to track your email down from my end.

    Thanks, I'm looking forward to getting this sorted for you! :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file