Browser Integration Broken

felixoifelixoi
edited April 27 in Linux Beta

Hey,

sadly I have to reach out to you again!
After version 0.9.33-39 my browser integration stopped working. I hoped it would be fixed with todays release but it isn't.

Application Log:

INFO  2021-04-28T00:01:46.890 op_executor:invocation_loop(ThreadId(17)) [status:op-app/src/app.rs:178] App::new(1Password for Linux/80033053 (EN_US), /home/felix/.config/1Password/1password.sqlite)
INFO  2021-04-28T00:01:46.890 tokio-runtime-worker(ThreadId(14)) [1P:native-messaging/op-native-core-integration/src/lib.rs:184] Starting IPC listener on 1Password-BrowserSupport
INFO  2021-04-28T00:01:46.891 tokio-runtime-worker(ThreadId(14)) [1P:native-messaging/op-native-core-integration/src/lib.rs:199] Active native core integration is awaiting messages
INFO  2021-04-28T00:01:46.898 op_executor:invocation_loop(ThreadId(17)) [1P:native-messaging/op-nm-installer/src/nix_utils.rs:53] Created NMH manifest at /home/felix/.config/google-chrome/NativeMessagingHosts/com.1password.1password.json
INFO  2021-04-28T00:01:46.898 op_executor:invocation_loop(ThreadId(17)) [1P:native-messaging/op-nm-installer/src/nix_utils.rs:78] Installed 1 Native Messaging Host manifests for Chromium
INFO  2021-04-28T00:01:46.898 op_executor:invocation_loop(ThreadId(17)) [1P:native-messaging/op-nm-installer/src/nix_utils.rs:53] Created NMH manifest at /home/felix/.mozilla/native-messaging-hosts/com.1password.1password.json
INFO  2021-04-28T00:01:46.898 op_executor:invocation_loop(ThreadId(17)) [1P:native-messaging/op-nm-installer/src/nix_utils.rs:78] Installed 1 Native Messaging Host manifests for Firefox
ERROR 2021-04-28T00:01:47.706 tokio-runtime-worker(ThreadId(3)) [1P:native-messaging/op-native-core-integration/src/connection_handler.rs:47] <redacted>: Linux(KeyringDecryption)
INFO  2021-04-28T00:02:56.189 tokio-runtime-worker(ThreadId(3)) [1P:op-data-layer/src/load.rs:143] loaded 156 items in 8 vaults for account: '<redacted>'
INFO  2021-04-28T00:02:56.232 op_executor:invocation_loop(ThreadId(17)) [1P:op-app/src/app/backend/unlock.rs:87] Lock state changed: Unlocked
INFO  2021-04-28T00:02:58.090 tokio-runtime-worker(ThreadId(3)) [1P:op-syncer/src/sync_job.rs:272] synced account '<redacted>' (0.158281577s)
INFO  2021-04-28T00:02:58.091 tokio-runtime-worker(ThreadId(3)) [1P:op-data-layer/src/file.rs:464] find_and_complete_pending_uploads: '<redacted>'
INFO  2021-04-28T00:02:58.650 tokio-runtime-worker(ThreadId(13)) [1P:op-data-layer/src/load.rs:242] The B5 Notifier for (DF4DW2MUZFCVPHL6LCU7SYASNM) has connected, now monitoring for events.
INFO  2021-04-28T00:04:19.349 tokio-runtime-worker(ThreadId(14)) [1P:op-syncer/src/sync_job.rs:272] synced account DF4DW2MUZFCVPHL6LCU7SYASNM (0.212445295s)

Extension Log:
https://gist.github.com/felixoi/9ede1ea62c0b613de0c80236493cf6ce

Opening the extension is not redirecting to the app, unlocking app/extension is not unlocking the counterpart.
Hope we will get fix figured out somehow.

Even if there are still bugs I have to give a huge shoutout to all of you! This linux app is just fantastic! I like it a lot more than the windows application even if this one is still beta! Keep doing this great work!

Thanks,
felixoi


1Password Version: 8.0.33-53.BETA
Extension Version: 1.25.4
OS Version: Manjaro 21.0.2
Sync Type: Not Provided

Comments

  • Dayton_agDayton_ag

    Team Member
    edited May 3

    Hey there @felixoi, I'm really sorry you're running into this issue! I've tested this out in up-to-date Manjaro and browser integration is working normally for me, so I think we may be able to get things up and running. Let's continue this conversation over email so we can dig into the logs. Could you send me an email at [email protected], and include my name in the subject line?

    After you email in, you should receive a Conversation ID that looks like this: [#ABC-12345-678]. Please paste that here, and I'll use it to track your email down from my end.

    Thanks, I'm looking forward to getting this sorted for you! :smile:

    ref: NDN-76893-544

  • I'm seeing some strange issues with browser integration, too. I'm using Kubuntu 20.04 with Firefox installed via the default apt repo, latest version of 1Password from the downloads.1password.com repo. I'll try to describe the situation as clearly as I can.

    1) 1Password foreground app is closed, but is running in the system tray (presumably analogous to 1Password Mini on other platforms).
    2) 1Password browser extension is locked.
    3) Click the browser extension. The app's unlock window pops up, not the extension's.
    4) Enter my master password, the animation seems to indicate it's unlocked. The app window disappears. But both the app and the extension still appear to be locked, and I can't use autofill.
    5) If I try to unlock the extension again, I go through the same process again, with the same outcome.

    Here are the workarounds I have found:

    • Unlock the 1Password app and leave it running in the foreground. Then the extension is unlocked already and the autofill functionality works.
    • Quit the 1Password app completely via system tray, and then click the extension. Opens the app in the background and works as normal.

    Hopefully this is helpful for tracking down the issue. I found the new behavior surprising!

  • I've started having a similar experience to @krackle.

    Ubuntu 20.04.02 LTS
    1Password app 80033053, on BETA channel
    1Password Beta add-on, 1.25.4
    Firefox 88.0-canonical-1.0

    If I unlock 1Password app and load it before launching Firefox, extension auto unlocks.
    If I started Firefox first, add-on won't launch/trigger 1Password app and will present its own login.
    If app autolocks after 10 minutes of inactivity, add-on won't launch/trigger 1Password app, and will present its own login.

    I don't know much about the inter-process communication in use between browser and extension - I am at a hotel using their WiFi, with a VPN on top of that at the moment - I do have a browser proxy set (SOCKS), but inactive (filled, but not turned on rn)... so wondering if perhaps that's having an impact.

    Also run NoScript, uBlock origin, and Greasemonkey.

  • Dayton_agDayton_ag

    Team Member

    Hey there @krackle and @adfhogan,

    I'm really sorry you both are running into these issues! I'd like to take a peek at the logs from your devices - could you both make a zipped copy of your .config/1Password/logs folder, and attach it in an email to [email protected]? Please add my name to the subject line so I can track it down on my end.

    Thanks to you both! I look forward to getting this back up and running. :smile:

  • katoxkatox

    Hi!

    Do you plan to support Vivaldi?

    The browser extension itself works (standalone) and the browser connect NMH Manifest is installed but the application fails with

    [1P:native-messaging/op-browser-support/src/main.rs:55] UnknownBrowser(/opt/vivaldi/vivaldi-bin)
            Happened in: native-messaging/op-browser-support/src/browser_verification/linux.rs:87
            Additional error context: /opt/vivaldi/vivaldi-bin isn't a supported browser
    
  • Dayton_agDayton_ag

    Team Member

    @katox:

    Great question! You can add Vivaldi to a "Supported browsers" list that will allow it to establish a connection between 1Password in your browser and the desktop app - I've linked a Forum post below with steps for getting it set up:

    1Password Support Community - Supported Browsers

    Let me know how it goes! :smile:

  • katoxkatox

    Thank you @Dayton_ag that resolved the issue. The browser extension icon doesn't change by itself to unlocked when I unlock the native application but it unlocks automatically when I click on it afterwards.

  • Dayton_agDayton_ag

    Team Member

    @katox

    That's great, I'm glad to hear that adding Vivaldi to supported_browsers got things running for you. :smile:

  • I was having the same problems as @krackle and @adfhogan.

    Oddly enough, I have two nearly identical computers here (Pop_OS 20.10, same browsers, same 1password versions, same everything really, they are almost exact clones). One of them worked fine, browse<->1password integration was fine and I could unlock and auto-fill from the browser fine. The other would attempt to work, try to unlock, present me with an password list to choose from, and then refuse to auto-fill unless I had the 1password open and unlocked in the foreground, as mentioned in the bug reports above.

    After poking around in the logs folder, I noticed that I was getting errors about invalid config values for 'closeAfter'. I had a vague recollection that on this failing computer I had at one time used the snap version of the app, then purged it and switched to the apt installer. The functioning machine always used the apt version. I wondered if the original snap install left some cruft around that was in an older, invalid format, and breaking something (causing the settings warnings). So, I purged the app off of this failing machine, deleted .config/1password completely, and reinstalled from apt again.

    So far anyhow, the problems have gone away, and all of my browsers correctly integrate with the running tray app, and I get correct prompts to unlock 1pass, presented me with options, and auto-filled as expected. This makes me wonder if the problem isn't possibly a remnant from a failed upgrade? Possibly something from snap->apt, but possibly from an old apt -> new apt, left user config out of sync with new requirements?

    In any event, its an annoying work around, but I was able to fix it by purging the app, all of its config data, and starting over.

    It wasn't a perfect experience though. On first run, the login process of the app sent me to the 1password site (with Firefox), but when I tried to select my account, it just kept sending me back to the 1password app and its "click here to login" message. Logs showed a notice of a malformed URL. I was able to use my emergency kit information to log in though, so all was worked out in the end.

  • Dayton_agDayton_ag

    Team Member

    @sillyotter

    I'm really sorry that you ran into these issues with 1Password!

    I noticed that I was getting errors about invalid config values for 'closeAfter'

    I believe that you're on the right track here - is it possible that, in the past, you had closeAfter set to 0? Earlier in the app's development setting this value to zero meant "never" and the app would not close automatically, but there was a need for this to change and a zero value became "immediately" - this would result in 1Password closing instantly afterwards. It's possible that this config file was still present on the system and 1Password read it when you switched from Snap to APT -I really do apologize for the trouble! I'm glad that things are up and running for you now.

    It wasn't a perfect experience though.

    Thank you for highlighting this. This current sign-in flow is on the team's radar for improvement. Currently, we suggest making use of the "Sign in manually" option.

  • Before making my post above, I did wipe my .config/1Password directory to no avail, but since the last updates (now 80033069, on BETA channel ... and Firefox add-on now 1.25.5) it seems to be behaving better for the time being, with 1Password app being launched from Firefox addon when it wasn't running.

  • Dayton_agDayton_ag

    Team Member

    Thanks for sharing the update, @adfhogan, I'm glad to hear that things are working smoothly for you now. :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file