Linux installer fails on libcurl4 and libc6

edited April 29 in Linux Beta

Hi! I bought a 1password subscription yesterday and have it working well on my iphone and through the Firefox extension on my desktop computer. I want to install the desktop version as well to see if it's even better, but I am having an issue with it. Running Linux Mint 18.3, processor architecture x86_64. I followed the instructions on your site (https://support.1password.com/getting-started-linux/#get-1password) but I run into an issue:

[email protected] /tmp $ sudo apt install 1password
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 1password : Depends: libcurl4 but it is not installable
             Depends: libc6 (>= 2.27) but 2.23-0ubuntu11.2 is to be installed
E: Unable to correct problems, you have held broken packages.

I've tried some things to fix this and am going to keep working at it, but so far I've have had no luck. Is this an issue anyone has encountered before or is it just my machine?


1Password Version: latest beta on site
Extension Version: Not Provided
OS Version: Linux Mint 18.3
Sync Type: Not Provided

Comments

  • SavanniSavanni

    Team Member

    Hi @JerryMaloney , and welcome to 1Password.

    Unfortunately, Mint 18.3 is quite old and is based on a very old version of Ubuntu which we do not support. You would need to upgrade at least Ubuntu 18.04, though we don't really test even there at this time. I would recommend upgrading to the latest version of Mint. I tested it on 20.1, and it installs and runs without trouble.

  • Looks like LTS for Mint 18 ends in 2 days! :o I hadn't realized. I will update that and try again. Thank you!

  • Dayton_agDayton_ag

    Team Member

    Sounds good @JerryMaloney! :smile:

  • Upgraded the OS to Mint 20 and got 1password installed without a hitch. Thanks, @Savanni !

  • BlakeBlake

    Team Member

    We're glad to hear that upgrading to Mint 20 got things kicked back into gear for you!

    Let us know if there's any other questions you have! 😊

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file