UX Improvements - Copy for RDP, show passwords & the new search

Little (but annoying) Bug report:
It is not possible to copy something from 1PW 8 into an RDP window.

UX improvement suggestions:
1. The universal search is cool, but it is missing two important features that make it useless for large environments with many passwords:

  • Search results must be prioritised, i.e. vaults, for example, should always be displayed as the first result, not in the middle of the list.
  • But even more important: You have to be able to filter by vault so that only results from this vault are displayed. We have many vaults with many entries that always have similar titles. Without being able to search in individual vaults, we unfortunately no longer find anything at all with the new search (for some search terms over 200 results).
  1. Create a "Show" button as available in the web version. There is so much space available, displaying more buttons would be a significant UX improvement (one less click each time). You need the show button for example for Windows logins on a server where copy paste is not possible.

Empty space in 1PW 8:

Web Version:


1Password Version: 8.1.0-66BETA
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: 1Password Business

Comments

  • I'm experiencing the same issue with RDP, and it's extremely annoying because it works about 10% of the time, so I always end up trying it, but it almost never works.

    To compare, in 1P7 on Windows, RDP pasting works 100% of the time, so it has to be something new with how the value is being copied in 1P8.

  • Oh I'm having this issue with RDP as well, it's very weird, some times it works and some times it just doesn't. Ctrl + I and drag and drop doesn't work on RDP and when you copy using the copy buttons in the UI, some times it says is was copied but when you paste it, it's as if you didn't copy at all.

  • In the meantime, I have noticed that the copy buttons do not work properly even in Windows (without RDP). Sometimes it works, but often not

  • Ah - I'm glad I'm not the only one who noticed this. I was going to post something, but I hadn't worked out if there was any definite way to trigger it, so I could post something helpful. I would agree I've noticed it works sometimes and not others. Not just restricted to RDP either.

    I have definitely noticed this issue when popping a 1Password entry out into a new separate window, then copying the password from that window into a newly created entry in the main 1Password window. (I'm sorting through old imported entries and setting them up properly).

    It doesn't happen all the time though - and it feels better since the recent update (81.2-2.BETA) - but I wouldn't like to say it's fixed, I just think I've noticed it less. That might be more to do with the work I've been doing though.

  • Dayton_agDayton_ag

    Team Member
    edited July 16

    Hey all,

    RDP/Clipboard

    Thanks so much for writing in with this feedback. Could you confirm if your RDP client is running as an elevated window? Additionally, could you confirm if copying plain text from other sources on your system (outside of the RDP) can be successfully pasted into the RDP? To confirm, is this happening both with drag-and-drop as well as using the copy button to copy the username/password to clipboard?

    @upwave:

    Search

    Thanks as well for this feedback! I can definitely see things from your viewpoint here, particularly narrowing search down to the vault contents (if you're viewing a particular vault), as well as the way we currently organize entries. Currently, we show vaults, and then we nest any entries in that vault that match the search term. I have reached out to the team to start a discussion on how this can be better handled.

    ref: /dev/core/core/#8744
    ref: /dev/core/core/#8745

    Reveal" Button on hover

    I can see how popping that Reveal button out onto the field itself would be handy! I'll pass this along to the Development team to see if this feature can be brought to the 1Password 8 early access. :smile:
    ref: /dev/projects/customer-feature-requests/#797

  • Hi @Dayton_ag, I've been playing with the copy and paste issue a bit, and I think I've found something that can trigger the issue. To answer your question about RDP though, no - I'm not using an elevated window.

    So I have seen this issue both in RDP (not all the time, but most of the time), and also in just general use but specifically when copying passwords or other data from 1Password to 1Password. This is because I'm trying to change some of my entries to a different type, so I open the old entry in a new window, then create the new entry in the main 1Password window. This morning it seemed to be working fine -> Create a new entry, hit the copy button on the username, paste it into the new entry, hit the copy on the password, paste it into the new entry. Then I tried copying the note text (there's no copy button here, so I selected it, then ctrl-c) and pasted it into the notes section of my new entry. I then just tried doing the username and password again using the buttons (not sure why I did this, but glad I did), and now they no longer copied and pasted properly. However - the interesting thing is, after copying a username or password and it NOT pasting into the new 1Password entry - I COULD paste it into Visual Studio Code (I'm sure something like notepad would be the same).

    I then tried the same thing with RDP - and the same kind of thing happened. Initially I could copy and paste using the copy button on the 1Password fields- but after I'd copied some text within RDP, I could then no longer copy and paste between 1Password and RDP - but I could still paste the field into my local Visual Studio Code.

    So it seems like when something else uses the clipboard, this perhaps upsets 1Password a little but not completely?

  • I have also tested a bit, but i can't find out what the problem is. It doesn't just affect RDP connections, but all windows. Sometimes it works, but most of the time it doesn't. Sometimes only in certain windows. In Firefox in particular, it no longer works if I have used Ctrl + C somewhere. Very strange.
    I don't know whats an elevated window is, it's just a "normal" rdp connection. Copy from other sources (and even from 1PW via Ctrl + C) always works. Never used drag&drop ;)

  • Dayton_agDayton_ag

    Team Member
    edited July 22

    Hey all, just wanted to let the thread know that I've been working on reproducing these behaviours, and I'll be following up with the Development team with our collective findings.

    Notably I can re-create @Upwave 's interesting find in that, once I've copied any bit of text from within Firefox, I can't copy/paste from 1Password back into Firefox. Even more puzzling is that, with Chrome and Firefox open side-by-side, Firefox pastes it's own copied text, whereas Chrome pastes the text I copied from 1Password. :sweat:

    We'll be digging into this to see what we can dig up. Thanks all! :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file