Double launch after macos 10.5 update

Hi,

I've just updated to macos 10.5.1 from 10.4.x. I have 1Password 6.8.9.

Even after many reboots, I can't launch 1Password. After a long timeout I get a window stating that I have multiple versions of 1Password, even if there is only one found, in the canonical path (see attached file).

If I kill the app and launch it from the Dock, I see a second 1Password icon and the same behaviour occurs again.

I've tried these docs but nothing worked :

I've attached the list of processes found via "ps" for the pattern "pass".

Thanks.


1Password Version: 6.8.9
Extension Version: Not Provided
OS Version: macos 10.5.1

Comments

  • ag_anaag_ana

    Team Member

    Hi @jlecour!

    Do you perhaps have a backup copy of the 1Password app on an external hard drive? Perhaps a Time Machine backup with a copy of your Applications folder too?

  • jlecourjlecour Junior Member

    Hi. No external drive or TimeMachine volume is mounted while I'm having this issue. And as you can see in my screenshot, there is only one copy in the list presented by 1Password.
    Also, I've been using 1Password for years without a single instance of this issue, then suddenly after the macos 10.4 to 10.5 update it's all broken.

  • ag_anaag_ana

    Team Member

    @jlecour:

    Thank you for the confirmation! I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • jlecourjlecour Junior Member

    Hi. I've just sent the diagnostic report. Thanks.

  • ag_anaag_ana

    Team Member

    Thank you @jlecour! Have you received a ticket number already?

  • jlecourjlecour Junior Member

    Hi,

    Here is my ticket number : [#PHX-83921-159]

    But I've got to say that I'm disappointed by the response I've had.
    Basically, 1Password 6 is no longer supported, and not supposed to work on the latest versions of macOS.
    This is strange because it used to work perfectly until this minor system upgrade.

    I've been advised to upgrade to 1Password 7, but this is an entirely different story ; technically (I don't control where the data is anymore) and financially (it's way more expensive in the long run).

    I'll write a full response to Alex Singer who analyzed my diagnostic report and wrote back.

    Thanks for the help and attention here.

  • ag_anaag_ana

    Team Member

    @jlecour:

    Understood, and thank you for sharing the ticket number! I see your email now, so I will let you continue the conversation over there :+1:

    ref: PHX-83921-159

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file