Purple "window constraints" window appears when opening app

chighchigh Junior Member
edited August 13 in Mac Beta

With the latest update (1Password 7 Version 7.8.8.BETA-0 (70808000) 1Password Beta), when I open the desktop app, a purple window appears and will not go away.

There looks to be something in reference to a size constraint because there's an arrow ↕︎ and the text in the window says:

"All specified constraints visualized"

Then the text is offset about half a line: "Why am I seeing this purple window (?)"

Text continues: "Layout is not ambiguous
Click a constraint to log it to the console"

But I'm not able to click on anything in the window or anything that seems to affect the window. This purple window goes away when I close 1Password and comes back once I open it again.

Refer to this screenshot:
https://www.dropbox.com/s/zziufebrd714iwi/Screen_Shot_2021-08-13_at_16_33_45.png?dl=0

Right now, I'm waiting for the troubleshooting app to generate a report to email.


1Password Version: 7.8.8.BETA-0 (70808000)
Extension Version: Not Provided
OS Version: 10.15.7

Comments

  • ag_tommyag_tommy

    Team Member

    @chigh

    The layout reporting (purple window) only appears in our betas. It's not a problem in the typical sense. It's more of a built-in feature to help our beta testers report issues before the specific version goes live.

    Did you intend to be on a beta? I only ask as some users have not realized they were on a beta. Can you tell me the steps you took to cause this behavior? Doing that will let me inform the developers and hopefully get a fix in the next beta.

    --

    To rectify the problem, can you try these steps, in order.

    1. Open and then quit 1Password completely using ⌘⌥⌃Q (Command Option Control Q)
    • You do not need to unlock the app to have it quit. 1Password must be the frontmost app when quitting.

      1. Open 1Password.

    *If the border reappears, you will need to quit and open 1Password again.

    If needed, we can move you off of the beta to a stable version, which will not exhibit this behavior. It's a small process and poses no harm to your data.

    --

    Feel free to answer my questions in your email and we can continue the discussion there. Thanks

  • chighchigh Junior Member

    I know I'm on the Beta; I specifically chose to run the beta versions to run it through all that I use it for. I use 1Password a lot, so I'm keen to help out where I can if I run into anything. I've just never had this come about before, so I was unaware of it and how to get rid of it.

    I got the notification that a new version was available. I updated, and as far as I remember, that window came up as soon as 1Password reopened after updating. However, I was also working at the time, so if I hit any combination of keys that opens that window, it's possible I did that. (Is it a key combination that opens it?)

    The steps you provided worked and the window is gone.

  • ag_tommyag_tommy

    Team Member
    edited August 13

    @chigh

    Thanks for those details. I wasn't able to reproduce it on Big Sur. Looks like I'll need to give it a go on Catalina and see where that leads me. I appreciate the report.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file