Safari Extension not working in latest Monterrey Beta

The Toolbar extension appears to be working, but the button on the fields is non-responsive.


1Password Version: 7.9.1 Beta-0
Extension Version: 7.9.1 Beta-0
OS Version: macOS 12 Beta 10

«1

Comments

  • mirvmirv Junior Member
    edited October 15

    I have had this problem for the last several Monterey beta builds. In Safari, it shows the 1Password button in the login/pw text fields, but it is non-responsive when you click on it. And there is no pull-down menu of password choices in the login field. However, in Safari Technology Preview, the 1P extension does work correctly. This started happening when I was still using a private vault with iCloud syncing, and switching to 1P membership did not change it.

    1Password version: 7.9.1 BETA-0 (70901000)
    Extension version: 7.9.1.BETA-0
    OS version: macOS 12.0 Beta (21A5552a)
    1Password vault type: 1P Membership (free trial)

  • Same thing on my setup, it used to be working, but just just went bad few weeks ago, mailed the support, did replied with some regular setups, such as reset experiental features, resintall, single user boot clearing, etc, all tried, none working.

    But, 1P8 and app store extension did works, but 1P8 sucked, so I have uninstalled it and went back to 1P7, but too sad, the extension inline menu just gone.

    I did inspected the elements, when I click on the 1P inline button, I can see the Shadow Contents for 1P was created, with comments "Closed", hover on the shadow contents, I can see a place holder around the text field, but it;s invisible actually.

  • mirvmirv Junior Member

    Oh I should mention that the toolbar 1Password icon continues to work, ie. bring up the normal Safari extension with the Autofill button. And cmd-\ still works as a shortcut to fill the login/pw fields.

  • @mirv Looks like the issue was fixed with the latest macOS version, 12.0.1, it's fine on my macOS now.

  • rudyrudy

    Team Member

    All,

    This one will be fixed by an apple-side update, there were changes in support of Safari Web Extensions that impacted something we were doing with our Safari App Extension.

  • mirvmirv Junior Member

    Yes I am now running macOS 12.0.1 (21A558) and I do believe it is working.

  • ag_anaag_ana

    Team Member

    That is good to hear @mirv, thank you for the update :+1:

  • mirvmirv Junior Member

    So this is indeed working, except there is a little problem with some sites. If I try logging into developer.apple.com/account , or appstoreconnect.apple.com , the 1Password extension pull down menu shows up but I can't click on any of the items. See screen shot. If I click on any of the menu items it doesn't do anything, I notice that the page changes the URL so I wonder if that could be the problem? I've attempted to attach a screen shot (some areas redacted).

  • mirvmirv Junior Member

    Note that this does work correctly on most sites. I just tried a few, like chase.com and mlb.com.

  • rudyrudy

    Team Member

    @mirv,

    do you have a file attachment on your apple id item?

  • mirvmirv Junior Member

    Yes. I just tried deleting the attachments on that item, and now filling on that site is working. So is this specific to the apple site or would it be a problem on any site for which I have an attachment in 1Password?

  • rudyrudy

    Team Member

    @mirv

    specific to the file attachment, I already have it fixed in the beta that is going out later today.

  • mirvmirv Junior Member

    Excellent!

  • ag_anaag_ana

    Team Member

    :+1::)

  • rudyrudy

    Team Member

    @mirv,

    That should be out now in 7.9.1.BETA-1, definitely let me know if that doesn't fix that for you.

  • I agree things appear to be back to normal with the latest betas of both Monterey & 1P. Thanks

  • rudyrudy

    Team Member

    @mikeormerod,

    Thanks for the confirmation.

  • Doesn't seem to be working. On 1Password 7.9.1 BETA 3, 1Password Helper isn't filling out forms at all in Safari on the release version of macOS Monetery.

  • OK, I can confirm that 7.9.1 Beta 3 doesn't work with release version of Safari on macOS Monterey. I downgraded to 1Password 7.9 release version and it is working again.

  • 7.8.1 beta 3 also does not fill forms in for me on Monterey.

  • TheMacMommyTheMacMommy Junior Member
    edited October 28

    I've just updated to 1Password 7 Version 7.9.1.BETA-3 (70901003) today and when I click the 1Password icon inside of the login field while using Safari, the login I need appears as usual, but now nothing happens when I click or press the return key. I am running macOS 11.6.1 (20G224).

    Here is what I've tried:
    (1) quit and restart both Safari and 1Password - no change
    (2) selected "Quit 1Password Completely" from the 1Password mini menu - no change
    (3) disable 1Password Safari extension, quit Safari, "Quit 1Password Completely" then relaunch Safari, then re-enable extension, then re-try - no change. Safari extension says it's version "7.9.1.BETA-3" I was going to try to uninstall it, but then I have to delete the whole app and start over and I don't have time for that at the moment.

    For the time being, I have to pin the login to the screen then manually copy and paste the username and password into the login fields. Command \ does not respond either. Nothing seems to make auto-fill happen at this time.

    Is anyone else experiencing this? What solutions have you tried? Should I roll back a version?

  • Gilles9Gilles9 Senior Member
    edited October 28

    You are right it is broken

    I am using MacOs 12.0.1, and I have tried the same as you did
    and tried restarting my Mac as well

    finally reverted to the released version, non-beta

  • I've also the same issue since 1Password 7 Version 7.9.1.BETA-3(70901003)

    I did the same steps as TheMacMommy and also:
    (1) Downgraded to Beta 2 (download & install)
    (2) Autofilling works fine in a few websites.
    (3) Upgraded (again) to Beta 3
    (4) Autofilling does not work

    The menu with a list of possible credentials does show up. Clicking on a specific credential does nothing.

    Safari: 15.1
    MacOS: 12.0.1 (M1 Mac-Mini)

    Temporarily workaround is downloading Beta 2 https://app-updates.agilebits.com/product_history/OPM7 or another older version.

    I hope Beta 4 (or a quick patch) will follow shortly ;)

  • I have the same issue with Safari and Chrome on Mac 12.0.1 and 1Password 7.9.1 BETA-3. Must copy paste entries from 1Password app rather than autofill via browser.

  • ag_tommyag_tommy

    Team Member

    Hey folks,

    I have done a bit of house cleaning, combining topics. Thank you for the reports we are looking into it.

  • ag_tommyag_tommy

    Team Member

    @TheMacMommy et al.

    Are you using the Safari app extension that is part of the beta or are you using the new 1Password for Safari? In Safari > Preferences > Extensions it would say version xxxxxx.

    7.9.1 beta 3 for the included extension or 2.1.3 for the 1Password for Safari.app (membership only). Please let me know.

  • Gilles9Gilles9 Senior Member

    Using "Safari app extension that is part of the beta"

    not the stand alone app for the extension as in V8

  • Same for me, Beta-3 is not auto-filling in Monterey. Downgrading to B2

  • Ok, I downgraded to B2 but the Safari extension is still showing B3 even though I un-installed it. Any ideas?

  • krgrahamkrgraham Member

    Another user confirming that 1PW stopped working with Safari 15.1 on Big Sur. 1Password for Safari extension appears to work but regular 1PW extension has stopped working again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file