In Chrome, disabling 1Password for "Payment methods" also disables auto-filling Passwords

patfornapatforna
edited November 22 in 1Password in the Browser

Hello,

I've been using 1password for a long time for all my passwords / logins. However, I do not want to use 1password for managing my credit cards or addresses.

Until a few weeks ago, in Chrome, it was perfectly possibly to enable 1Password to auto-fill passwords but not payment methods or addresses (via chrome://settings/autofill).

However, it seems that a recent release of 1password or chrome has introduced a problem. Although the 3 distinct settings still exist in Chrome, when I disable 1 password for controlling payment methods or addresses, it get's disabled completely.

This is incredibly frustrating and it's turning into a showstopper for me and my family to use 1password.

Can you please describe a workaround or fix the issue and restore the expected behaviour?

1Password extension version: 2.1.4
Chrome version: 95.0.4638.69

Cheers,
patric


1Password Version: 7.9.1
Extension Version: 2.1.4
OS Version: macOS 12.0.1

Comments

  • ag_anaag_ana

    Team Member

    Hi @patforna!

    Although the 3 distinct settings still exist in Chrome, when I disable 1 password for controlling payment methods or addresses, it get's disabled completely.
    Can you please describe a workaround or fix the issue and restore the expected behaviour?

    I don't think anything changed recently here. Can you please elaborate what you mean when you say that "1Password gets disabled completely"?

  • Can you please elaborate what you mean when you say that "1Password gets disabled completely"?

    When I disable 1Password from controlling "Payment methods" or "Addresses and more" (see chrome://settings/autofill), it completely disappears from those settings, i.e. even in "Passwords" without a way for me to enable it just for this setting.

  • BenBen AWS Team

    Team Member

    @patforna

    I see. I think that's just how Chrome's settings work now, unfortunately. 🙁Regardless of those settings, you should still be able to activate 1Password from the Chrome toolbar by clicking on its icon, and then fill as desired from there. Do you see that option? If not, please try clicking on the "puzzle piece" icon and then click the pin next to 1Password. Alternatively, you can use the keyboard shortcut to activate 1Password.

    Does that help? Please let us know.

    Ben

  • I've been using 1Password and Chrome for several years now and this has always worked until a few weeks ago (when I also noticed some UI changes in the 1Password extension - it now shows little icons in the input fields). So this is definitely a regression.

    When I disable the setting in chrome, it also disables the extension (hence I can't do what you suggest). When I re-enable the extension, then it controls all three settings again.

    Are you saying this is a Chrome issue then? I would find it rather strange UX to have the three separate settings but not able to control them separately.

    I can of course work around the issue by just copy/pasting from the 1password app but that makes for a terrible user experience. I really don't want 1password to manage auto-filling my credit cards and addresses because the chrome/google experience is much smoother on android for this.

    I've been very happy with 1password over the years but this really feels like a big step backwards for me =(

    Hopefully for me and other users facing the same issue this can be addressed soon.

  • ag_anaag_ana

    Team Member

    @patforna:

    As Ben wrote, things should work regardless of the Chrome configuration. What is the value of this preference in your 1Password extension settings page?

    I've been using 1Password and Chrome for several years now and this has always worked until a few weeks ago (when I also noticed some UI changes in the 1Password extension - it now shows little icons in the input fields). So this is definitely a regression.

    Are you referring to the 1Password classic extension? I wonder if you actually switched extensions, rather than simply updating the one you had:

    Get the 1Password classic extension

  • Aha! That seems to have been it. I switched back to the classic extension and things work again as expected \o/.

    I still think the behaviour is broken in the non-classis extension but this workaround works for me.

    Thanks!

  • I have had the same issue after upgrading to 1Password for Windows 10 v8.4.0
    I followed the steps to revert back to the classic extension, but now when trying to use 1Password in Chrome, I get redirected to a page that says 'Looking for the 1Password helper'

  • @kevriley I'm using v8 on Windows 10 too. As far as I know, classic extension only works for older versions of 1Password and not with 8.

  • ag_anaag_ana

    Team Member

    @patforna:

    Aha! That seems to have been it. I switched back to the classic extension and things work again as expected \o/.

    That is great to hear, I am glad I could help :)

  • ag_anaag_ana

    Team Member

    @kevriley:

    J.M is correct: if you are using 1Password 8 you cannot use the classic extension, that is only supported up to 1Password version 7.

  • @ag_ana thanks for confirming, and thanks @J.M
    So this now takes me full circle - using the new browser extension, how can I stop 1Password from auto-filling addresses? I want it to do passwords, but not take away the address (and possibly payment methods) from Chrome.

    Feels like this is not currently possible?

  • Hey @kevriley:

    If you'd like 1Password to offer passwords, but use Chrome to offer addresses and payment methods:
    1. Right-click 1Password's icon in Chrome's toolbar and click Settings.
    1. Under "General" turn off the "make 1Password the default password manager" option.
    1. Paste the following into Chrome's address bar: chrome://settings/autofill
    1. Click Addresses and more and allow Chrome to autofill.

    If you have addresses and payment methods saved in 1Password and you would prefer 1Password to not conflict with Chrome's addresses and payment methods, disabling "Show autofill menu on field focus", also in 1Password in the browser's settings will prevent 1Password from showing the autofill menu, instead requiring clicking the 1Password icon in a field to show filling suggestions. Let me know how that works for you!

    Jack

  • @jack.platten that seems to be exactly what I wanted. Thanks!

  • ag_anaag_ana

    Team Member

    On behalf of Jack, you are welcome @kevriley! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file