Turn-off Markdown in Chrome+Firefox extensions: HOW??

As per title. The text in my notes are all screwed up, with half the text normal size, the other half at double text size when viewed in the Chrome+Firefox extensions. How do we turn off Markup screwing up this - no setting I can find anywhere??

And yes, I have Markup turned-off in the main app settings.

(Additionally, Markup should be enabled PER ITEM by now, which has been complained about for months on end. Yet still not done.)


1Password Version: 7.9.1
Extension Version: 2.1.4
OS Version: macOS 12.0.1
Referrer: forum-search:markdown chrome

Comments

  • ag_yaronag_yaron 1Password Alumni

    Hey @jimthing ,
    It is currently not possible to turn off markdown in the extension. You can edit your notes to remove any markdown symbols/signs by checking which ones do trigger markdown: https://support.1password.com/markdown/

    Thanks for sharing your thoughts and feedback here, I'll add your voice to an existing feature request to add an option to turn this off. :+1:

    ref: dev/core/core#1190

  • That's can't be right, surely? It'd be completely and utterly ridiculous, as it makes Secure Notes suddenly completely unusable in about half a users' 1P access points.

    On macOS, AFAICS the issue is with non-Safari (i.e. Chrome, Firefox, et al.) extensions, which are downloaded separately, compared to the Safari extension that comes with the 1P macOS app (though there is a weird separate "1Password for Safari" available in the Mac App Store too – what's that for?).

    The in-browser settings panels on non-Safari extensions do not have the simple "Format secure notes using Markdown" option, seen in the main 1P app settings, that presumably sets the flag on/off in the Safari browser extension as well.

    This seems a major oversight if true, as it causes mass chaos to users' text data, if needing to use inside the browser extension.

    The suggestion to "edit your notes to remove any markdown symbols/signs" is completely invalid, as I (and presumably most other users are not using the markdown symbols for formatting in the first place – they are just parts of the main text body, so cannot be simply deleted or altered in such a manner.

    **Given the chaos this causes in many users access points for our 1P data, surely this bug has been scheduled to be fixed sometime soon, has it?
    **

  • ag_yaronag_yaron 1Password Alumni
    edited December 2021

    Hey @jimthing ,
    Thanks for your feedback and input here, it is much appreciated!

    This is not a bug, but rather a feature that has not (yet) been implemented in our standalone extension entitled "1Password for the browser" or "1Password for Safari".
    The current Safari extension you have is a part of the 1Password 7 desktop app and therefor adhere to its settings and preferences, but the extension in other browsers does not.

    I definitely can see that this is messing up your experience and I apologize for that. We haven't had almost any other reports or complaints on this from other users so this feature request is not considered high priority at the moment. Markdown is quite a popular feature that most users enjoy and use often judging by the reports and data that we've got.

    Regardless, you are right that there should be a way to turn it off in the extension as well, and I hope we will be able to implement this feature at some point in the future.

    Thanks again for sharing your thoughts and feelings on the matter, I'll forward it to the team :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file