Both Chrome and Firefox add-ons no longer in sync with 1password for Windows (all beta)

I'm on Windows beta 8.8.0 (80800126). I'm also using the Chrome and Firefox beta add-ons. Firefox and Chrome using add-on version 2.3.5

For quite some time, logging in to 1Password for Windows has also logged me in to the Chrome and Firefox add-ons. As of today, however, this is no longer working. I have to separately log in to 1Password from each browser. Furthermore, if I close the browser, I am logged out of 1Password.

I have confirmed that 1Password for Windows is unlocked all during this.


1Password Version: 8.8.0 80800126
Extension Version: 2.3.5
OS Version: Windows 10 21H2 OS Build 19044.1741

Comments

  • Jack.P_1PJack.P_1P

    Team Member

    Hi @quagmire:

    Thanks for letting us know about this. We're actively investigating this, so please keep an eye out for updates.

    Jack

    ref: dev/core/core#15802

  • rzzzrzzz
    Community Member

    Same here with desktop app version 8.7.1

  • Jack.P_1PJack.P_1P

    Team Member

    Hi @rzzz and @quagmire:

    Thanks for following up.

    There is an issue with our signing certificate that is affecting 1Password 7 and 8 for Windows, resulting in some customers having trouble with updating or installing 1Password as well as the browser integration. We're working on getting this resolved, and appreciate your patience. In the meantime, please know that this is not a security issue and 1Password is safe to use.

    If you're having trouble with 1Password, the best workaround is to use 1Password in your browser without integrating with 1Password for Windows: right-click the 1Password icon in your browser's toolbar, choose Settings, and turn off the "Integrate with 1Password app" option.

    Jack

  • quagmirequagmire
    Community Member

    Thanks for the update!

  • ManaburnerManaburner
    Community Member

    I was about to report the same ^^ Thought it was me who made a mistake but I'm glad that others see this problem was well. Will keep an eye on this post

  • rzzzrzzz
    Community Member

    I upgraded my desktop app by changing channel from production to beta (8.8.0), it fixed the link issue. Now my browser extensions can unlock without re-entering the password.

  • donatom3donatom3
    Community Member

    Thought it was my upgrade to windows 22h2. I can't even change from produciton to Beta it's giving me an error on restarting the app.

  • quagmirequagmire
    Community Member

    I've just downloaded a new Windows beta - 80800141 - that seems to fix the problem.

  • ManaburnerManaburner
    Community Member

    80800141 fixes it for me as well

  • Jack.P_1PJack.P_1P

    Team Member
    edited June 15

    Hi @Manaburner / @quagmire / @donatom3 / @rzzz:

    We've released new builds of 1Password 8 on all three of the release channels using our new signing certificate that resolves the issue. Below is the version number you'll need to see to ensure that the version you're on is using our new certificate.

    Production: 8.7.2-2 or later
    Beta: 8.8.0-141 or later
    Nightly: 8.8.0.140 or later

    If you're still running into trouble @donatom3, you can download 8.7.2-2 from our downloads page here: https://1password.com/downloads/windows/

    After updating to the newest version of 1Password 8, you can re-enable the integration between the desktop app and 1Password in your browser. Thanks for your patience on this!

    Jack

  • ManaburnerManaburner
    Community Member

    Thank you @Jack.P_1P

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file