Read first: Previous version support information


Fidelity logins stopped working on Firefox.

bobebobe Junior Member
Community Member

Firefox 21.0, 1Password Extension 3.9.17, 1Password 1.0.9.322
Logins to Fidelity and Fidelity NetBenefits stopped working this week after 1Password update to 1.0.9.322.

Bob

Comments

  • MrCMrC
    Volunteer Moderator

    It worked for me here using https://www.fidelity.com and the extension.

  • AGKyleAGKyle AgileSupport
    1Password Alumni

    Hi Bobe

    Have you tried resaving the login?

    • Open the site and visit the login page
    • Type in your username and password
    • Click the 1Password extension button
    • Click the + button in the extension window
    • Rename the Title field to something unique and identifiable
    • Click Save

    Most often this will fix any weird errant issues with many sites.

    Let us know how it turns out!

  • bobebobe Junior Member
    Community Member

    Saved another copy of the username and password. All looks good in the edit fields; however, login fails. When I try again enter username and password with 1Password and then retype password it still fails. Repeat the procedure and retype username and in works.

    Tried the URL that MrC suggested and it works. But, if you log out and then back in the url is https://login.fidelity.com/ftgw/Fidelity/RtlCust/Login/Init and login fails.

    NetBenefits still does not work.

    Bob

  • khadkhad Social Choreographer
    1Password Alumni

    https://www.fidelity.com/ is the URL I use for my Fidelity account and it works well in all my testing. What is the URL for the other thing you are referring to? I'm not familiar with it.

  • bobebobe Junior Member
    Community Member

    To see the problem at www.fidelity.com, go to the site and login with the "remember me" unchecked. Then log out and click on login. You should be at a different page for logins. You also should have no username saved. Use 1Password to login and I get a login error. If the username is saved, there is no error. Our household has three usernames for Fidelity, which is the reason I do not use "remember" usernames.

    NetBenefits is the Fidelity 401k website and the URL is at https://workplaceservices300.fidelity.com/NBHome.html or at www.fidelity.com and select NetBenefits as the start page. Both demonstrate the same behavior as the www.fidelity.com described above.

    It appears that the problem only occurs on the second login page (after a log out) and when usernames are not remembered.

    Bob

  • khadkhad Social Choreographer
    1Password Alumni

    Please edit your Login item and make sure that your actual username is listed. Fidelity performs some client-side obfuscation which means that if you just save a Login with 1Password then the username will have a bunch of asterisks in it. Make sure to edit the item and enter your correct username without any asterisks.

    Does that help?

  • bobebobe Junior Member
    Community Member

    In 1Password, there are two fields saved for the username. One is named SSN-visible, the Value is asterisks with the last three characters of the username, the Type is text and the Designation is none. The second is named SSN, the Value is the actual username, the Type is text and the Designation is username.

    Deleting the SSN-Visible field does not work as the entry is left blank for the login. Also, the problem is not unique to Firefox, I get the same results with Chrome Version 27.0.1453.110 m. khad, can you reproduce the problem with your Fidelity account?

    Bob

  • khadkhad Social Choreographer
    1Password Alumni

    Bob, I cannot reproduce any problem. Please edit the value with the asterisks to be your actual username. Make sure it is your full, correct username without any asterisks in it.

  • bobebobe Junior Member
    Community Member
    edited June 2013

    First, I have edited the username. Second, 1Password did not work correctly in either Firefox or Chrome.

    Third, the problem is that there are different field names between www.fidelity.com and the "Log in again" screen. For example, the username field at www.fidelity.com is " text_id" and it is "SSN" on the "Log in again" screen.

    1. Values saved from the www.fidelity.com work on both if the username is "Remembered".

    2. Values saved from the www,fidelity.com do not work on the "Log in again" screen if the username is not "Remembered".

    3. Values saved from the "Log in again" screen work on www.fidelity.com whether the username is "Remembered" or not.

    4. Values saved from the "Log in again" screen do not work on the "Log in again" screen if the username is "Remembered".

    I will use the #1 above from now on, although it requires extra steps.

    Bob

  • khadkhad Social Choreographer
    1Password Alumni

    I really wish I could reproduce this. I would love to get it resolved for you. I saved a brand new Fidelity Login item one more time and simply changed the masked username with the asterisks to my actual username without asterisks and it works for me in Safari, Firefox, Chrome, on the main page, and on the page that comes up after I log out of my Fidelity account. I fear we may need to have you use the method that you said does work for you for now until we can get some more data on this perhaps from another Fidelity user.

  • bobebobe Junior Member
    Community Member

    Thanks for your time. Bob

  • khadkhad Social Choreographer
    1Password Alumni

    I am happy to help. We'll keep an eye on this and keep working to improve things.

  • bobebobe Junior Member
    Community Member

    As a followup, the root cause of the problem is that Fidelity uses a different names for the username field. At www.fidelity.com it is "temp_id"; on the "login again" url, it is "SSN". Putting both username fields in the single 1Password entry for each user totally solves the problem. This works on both Fidelity and Fidelity NetBenefits as long as no usernames are saved via the "remember me" checkbox.
    Bob

  • khadkhad Social Choreographer
    1Password Alumni

    Awesome! Thanks for following up, Bob. I am glad things are working well for you now too. :D

This discussion has been closed.