1Password Safari extension is difficult to use.

First, it loads very slowly each time I need to access it. Second, it rarely autofills and one time I couldn't get it past the permission window and so had to turn to the desktop version and copy name and password manually. And then, the first problem comes back since I have to go back to the extension first for my name and then for my password. Each time I have to start over.


1Password Version: 8.9.4
Extension Version: 2.3.7
OS Version: Mac OS 12.5.1
Browser:_ Safari
Referrer: forum-search:1Password in Safari doesn't fill in passwords automatically'

Comments

  • Joy_1PJoy_1P

    Team Member

    Hey @Rebdan, sorry about the troubles you are seeing. If the extension does not have the right permissions, then it will not fill. To fix that, please do the following:

    1. Open Safari > Preferences > Websites > 1Password for Safari.
    2. Make sure that all the sites listed in the window are set to "Allow".
    3. Make sure that "for other websites" is set to "Allow".

    Here is a screenshot: https://share.cleanshot.com/yIVZga

    After that, please close the window and fully quit the browser. Fully quit the 1Password app. Restart both and then test things out. Let us know how that goes.

  • RebdanRebdan
    Community Member

    Thanks. It seems to be back at the familiar from before.

  • ag_tommyag_tommy

    Team Member

    Let us know if that should happen to change.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file