Login issues with NAB Internet Banking site

sjksjk oversoul 1Password Alumni
This discussion was created from comments split from: Accessing Banks.
«13

Comments

  • I have tried using the methodology you specify above - same outcome.

    The error is that the password is incorrect. I have just checked and this also happens at NAB.COM.AU. I have taken screen shots but would prefer not to post them online. I could send direct.

    Please note that others are working well - Amazon, Yahoo etc....

  • sjksjk oversoul 1Password Alumni

    Hi @Heffor1,

    Are you getting these results when opening the web page first, then filling with 1Password?

    Can you try temporarily disabling auto-submit, open the page, fill with 1Password, manually submit, and let me know if that behaves any differently?

    To get the login page for nab.com.au, you first need to click this Login button to open the separate page for 1Password to fill:

    If you're still unable to get any of this working let's continue troubleshooting it through email. Do do that, please send us a Diagnostics Report from your Mac, along with a link to this topic and your forum username, to [email protected]. You can also attach any screenshots if you'd like. A brief comment here mentioning that you've sent the report would also be helpful. Thanks in advance!

  • I have run and sent the report via eMail. Looking forward to your response.

  • sjksjk oversoul 1Password Alumni

    Thanks, @Heffor1. We've got your report and other information. Someone from our support team will be helping you directly through email to resolve these issues with filling and submitting.

    .

  • edited May 2014

    I, too, am having issues with NAB internet banking. My 1password skips the main page and goes directly to the login page (https://ib.nab.com.au/nabib/index.jsp) and fills the fields but then the auto-submit process results in this page (https://ib.nab.com.au/nabib/login.ctl?error=201001) During the auto-submit it looks as though the fields seem to clear the input data but I could be mistaken.
    Turning off the auto-submit results in a correct login.
    I'm using v.4.4 and the Safari browser extension 4.1.0 on Mavericks 10.9.3 with Safari 7.0.3.

  • sjksjk oversoul 1Password Alumni

    Hi @Online_Alias,

    I'm sorry you're also having issues with 1Password on the NAB Internet Banking site . Here are a few things to try, with autosubmit enabled:

    Please let me know if any of that is helpful.

  • edited May 2014

    Hi @sjk,

    I added the https://ib.nab.com.au/nabib/index.jsp URL as an additional website and tried the "open and fill" option with auto-submit on. It resulted in the error.

    I also opened the above URL page and used the Command-\ kb shortcut. The fields populated but after auto-submit occurred the result was the same error.
    I tried both the previous points with the "Animate form filling" option disabled but the "Submit when enabled" option on.

    I also tried with the Submit option set to "Always." Each time the result was the same error.
    If I set the Submit option to "Never," the saved field inputs correctly populate the fields and manual submission of said inputs logs in normally.

    Any suggestions?

  • sjksjk oversoul 1Password Alumni

    Hi @Online_Alias,

    Thanks for doing those tests and posting the results. For the moment it looks like a workaround would be to set the item's submit option to Never submit.

    Improvements in the upcoming 4.2 extension might resolve this issue, although I don't have an actual account to test with. If you'd like to give the 4.2 beta extension a try, open the 1Password Extension page in your browser, then select Enable betas before clicking the big green Install button. Then restart the browser. Reverting to the stable 4.1 release is relatively easy with Safari by simply reinstalling it. :)

  • Hi @sjk‌,

    After installing the 4.2.0.b21 extension, I tested the login with the Submit option set to Never, Submit when enabled, and Always. Each test resulted in the fields being correctly populated but no auto-submit occurred.

    The plot thickens...

  • sjksjk oversoul 1Password Alumni

    Hi @Online_Alias,

    You haven't mentioned whether you purchased 1Password directly from our website or from the Mac App Store, but if you did purchase from the Mac App Store then here's something that should give you better results with autosubmit:

    Please download and run this Autosubmit Script and let me know if that makes any difference.

    If you did purchase 1Password directly from our website then the script won't help you and we'll continue to investigate other options. Thanks!

  • edited May 2014

    Hi @sjk‌

    After running the linked script the login performs correctly with auto-submit under both 4.1.0 and 4.2.0.b21 extensions. The app purchase was from the MAS.

    Thanks for your time and patience troubleshooting my problem.

  • sjksjk oversoul 1Password Alumni

    That's excellent, @Online_Alias. Thank you for all your help with zeroing in on what turned out to be a simple solution! I think the original autosubmit error you reported was trying to steer us away from it. :)

  • The beta with the auto submit script worked for me for NAB and Standard Chartered. Will the auto submit script be incorporated into future updates? What is the risk of me continuing to work with the Beta?

  • sjksjk oversoul 1Password Alumni

    Also excellent, @Heffor1. :)

    I see Chris' email to you also suggested installing that script. Its future is unknown at the moment, although if it continues to be an extra download/install we can make that more visible and convenient (e.g. integrated with extension installation).

    There's really no "risk" using either the beta or stable extension even if they behave differently in some cases (with the beta's intended to be preferable). And the current 4.2 beta is a release candidate.

  • Upgraded to the latest release of 1Password and the problem with accessing banks is back. Should I rerun the script or reinstall the extension?

  • sjksjk oversoul 1Password Alumni

    Hi @Heffor1,

    I'm sorry to hear that the trouble you've had using 1Password with banking sites has returned. Is it still these pages (at least) giving you problems?

    https://pvm.standardchartered.com/nfs/login.htm?lang=en_US

    https://ibank.standardchartered.com.sg/nfs/login.htm

    https://ib.nab.com.au/nabib/index.jsp

    Autofill and autosubmit are both working as expected using previously created test items, with version 4.4.1 (Mac App Store) of the main application and version 4.2.1 of the extension for Safari, Chrome, and Firefox. However, I don't have valid account credentials to verify successful logins.

    Reinstallation of the autosubmit script is unnecessary. It's a one-time installation on each system where 1Password will use it.

    Reinstallation of the browser extension(s) shouldn't make any difference but there's no harm doing it. At least confirming you're running version 4.2.1 (or newer) would be a good idea.

    Have you (re)tried manually saving a new Login item for any of the pages? You could also try restarting 1Password mini and web browser(s). If that doesn't help, then restart your system.

    And if you're still stuck after that then let's move this back to email and get it resolved. Sending us a fresh Diagnostics Report (like you originally did after post #15) would be helpful. Thank you!

  • I too am having trouble with nab.com.au and the non-App Store version of 1Password for Mac (version 4.4). It's not clear from this thread whether this has been resolved in a future update or not, so thought I'd chime in.

    The problem seems to be that 1Password is populating both the userid and the password fields with my userid. I've tried all the usual tricks - manually creating a 1Password item, disabling auto-submit etc. The web form details stored against my 1Password items do have the same field names as those used by NAB, so I'm at a loss.

  • sjksjk oversoul 1Password Alumni

    Hi @smacpherson,

    I'm sorry that site is troublesome for you with 1Password, too. Here's what I'd like you to try:

    Please let me know if that works for you.

  • Thanks @sjk‌, that seems to have worked! To satisfy my own curiosity, I've been playing around with the newly created login item, and have ended up making it look exactly like the old one I had - same URL, same web form field names etc., and the new one continues to work. What could be lurking in the old item which is causing it to fail?

  • Try comparing the web form details of each item to see if there's a difference. Edit them, go towards the bottom and click on show web form details.

    Stephen

  • Yep, the web form details are the same between the two 1Password items as well, and the labels used for the two form fields in these items match the HTML form element name attributes on NAB's site. I've never experienced this with 1Password before, and I've been using it for years, but now I know what to try if the weirdness ever returns.

  • sjksjk oversoul 1Password Alumni

    That's interesting, @smacpherson.

    When creating a Login item for the https://ib.nab.com.au/nabib/index.jsp page using Save new Login in 1Password mini, its web form details look like this:

    And that item fills the page's NAB ID and Password fields with the userid field value, the latter mistakenly.

    When creating an item from the main app, its web form details look like this:

    And both fields on the page fill correctly.

    Only difference is the label for the web form field associated with the username. The userid label causes trouble for filling; the username label doesn't.

  • edited June 2014

    That makes sense @sjk‌, as the main application doesn't know what the HTML fields will be labelled, but 1Password mini is intelligent enough to figure out which fields are which. Unfortunately I'm not quite seeing the same thing as you - both my 1Password items were created using the browser extension, and both have "userid" fields. I can't see any difference between the item that works and the item that doesn't!

    Newly created item which works fine:

    Newly created item which works fine

    Item which recently stopped working:

    Item which recently stopped working

  • sjksjk oversoul 1Password Alumni
    edited June 2014

    It gets more interesting, @smacpherson. :)

    If you don't mind, we'd like to get more details about those (non-)working items. Just drop us email at [email protected], including a link to this topic and your forum username, and we'll follow up with you there. Thanks!

    .

  • I have just started a trial of 1Password 4 OS/X and was not impressed with the various issues I was having, especially since my main bank is the NAB. Following the steps above, I can confirm that this likewise fixes my NAB login problem. As well, I can confirm that by changing the username field on the working NAB login to userid, still continues to work.

    Clearly, there is something under the covers that is not visible for one to work and one to fail. But, the broken NAB Login can be fixed by changing the userid to username, as would be expected.

  • sjksjk oversoul 1Password Alumni

    Hi @fifo1956,

    Thanks for your feedback about this NAB login problem. I'm glad you were able to get it working.

    An item with userid as the username web form field label that can fills both page fields correctly, like @smacpherson has, may shed more light on this.

    We'd be glad to help you out with any other issues you're still having with 1Password. Feel free to start a new topic if unrelated to this one. Thanks!

  • Hello

    I am also experiencing issues with auto fill for NAB.
    I have followed the instructions related to adding a fresh login but still get the error.
    I have the username field.
    I can only make it work using manual copy and past of the login and password separately.

    I am using Mac App store version 4.4.1(441006)
    I have installed the auto submit script/patch
    I am using Safari 7.0.4

    What is interesting is that the iOS app auto fills the login and password perfectly when using the built in browser.

    Please let me know what you you need me to do next to get my one sorted.

  • MeganMegan

    Team Member

    Hi @StretchGSK,

    I'm sorry that you're having trouble here. Could you please confirm how you created the new Login? You should be able to create a working Login with the appropriate fields in the web form details by following these steps:

    • Edit the login that you currently have for this website by appending an "Old" to the title - just so you can tell them apart.
    • Visit the site and fill in the fields you want filled. Do NOT click the login button.
    • Click the 1Password extension, and unlock it if necessary.
    • Click the gear icon (or vault icon if multiple vaults are enabled) in the upper right corner.
    • Select Save new login.
    • Give the entry a unique and identifiable title.
    • Click Save.
    • Revisit the site and see if 1Password fills in the site correctly.

    I'll keep my fingers crossed that saving a Login in this manner gives you the appropriate fields in web form details. :)

  • Hi Megan

    I had tried using a fresh login but I did it manually the first time.
    I have followed your instructions and still have an error.

    But it is slightly different this time in that it looks as if it is auto filling my username in the password field.
    I am guessing this as it is now a much shorted entry for password compared to my actual password s well as the auto fill from my "old" login"

  • sjksjk oversoul 1Password Alumni
    edited July 2014

    Hi @StretchGSK,

    Can you try creating a new Login item for the NAB page using the main 1Password application and let us know your results of testing with it? See post #19 for more detailed steps. Thanks!

This discussion has been closed.