Google multi-page login [need to fill on each page: "Fill Login on current webpage" shortcut]

primeprime
edited September 2015 in 1Password in the Browser

Have you guys seen this?

"And of course, most of the popular password managers used today now don’t work with the new Gmail login screen, though this is likely a temporary situation. (LastPass, for example, says its fix will be released today)."

http://techcrunch.com/2015/05/13/gmails-new-login-screens-hints-at-a-future-beyond-passwords/#.0t3f7p:0vMt

«1

Comments

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @prime and @wkleem,

    Well I've just visited gmail.com and I was lucky enough to be greeted by the new page. My existing Login items work without alteration. Please do let us know if this isn't the case for you but I won't have to change my Login items at all :smile:

  • I haven't tried, and I don't use Google also that much anymore. I posted this in case 1Password needs to tweak something for users who use this.

  • brentybrenty 1Password Alumni
    edited May 2015

    @prime: Indeed. Thanks for the head up!

    Often changes like this break logins depending on how and where they were saved to begin with. I haven't run into any issues with the new form myself, but if anyone does, often simply resaving the login helps — especially if done on the page where you're having trouble. Cheers! :)

  • The change really does cause a problem, though -- because the login process is effectively split up into two pages now, 1Password doesn't seem able to fill out both forms automatically by using just one entry. I resaved the login, and the problem is still present. (At least that's the case when you don't want to keep your email registered on the gmail site -- which I definitely don't want to.)

    This is hugely annoying, and I would be glad if Agile could come up with a workaround asap -- seems like Lastpass, for example, recommends using a script which inserts a delay between the input of the username and the password, which seems to fix the problem.

    Keep us up to date, will you? Maybe even on the blog?

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @hspielmann,

    Just to make sure I don't misunderstand, is the request that a single ⌘\ fills in both pages without further user interaction compared to being required to use ⌘\ twice at the moment?

  • My comments relate to the Windows version of 1Password. Am I correct in thinking you now need two logins (e.g. "Gmail Page #1" and "Gmail Page #2")? Page #1 now seems to be username only and page #2 is now password only (plus a tick box saying something like "keep me logged in") - I would also like to automatically deselect this tick box. Currently I'm using copy and paste to get the username and password separately.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @PJCallow,

    A single Login item will work in 1Password for Windows. Here is what you need to do.

    1. On the first screen of Google's login page enter your email address as normal and save a Login item. Then click on the Next button.
    2. On the second page uncheck the tick box for staying signed in and enter your password. Go to save a new Login item but change the option menu from Create new Login to Replace accounts.google.com (or whatever title you gave your Login item in step 1).
    3. Do not tick the checkbox titled Replace password only, leave it disabled. Just click Save. If you're unsure at all, below is a screenshot of what you should be seeing before clicking Save to update the Login from step 1.

    You're done :smile: If you have any troubles please do post back here but this created a working and Login item (singular) that worked across both screens for me.

    Here's the partial screenshot I referred to in step 3.

  • edited May 2015

    Hi @littlebobbytables

    @PJCallow has described the situation as it presents itself to me, too.

    And thanks for your instructions! Unfortunately, they are not working, either. It's weird, I had a small success the first time I tried it -- 1Password successfully entered the email and changed to the second page -- however, it didn't succeed in assigning the password.

    I tried to delete the login and repeat the steps, and this time, it does not even get that far -- it stops on the first screen with the message "Insert password" (or the German equivalent, in my case).

    I could reproduce the first minor success (that is an automatic login that inserts the email address and takes me to the page where the password should be inserted) by manually replacing the URL -- which in the automatically created Login item was a rather long, convoluted string -- with https://mail.google.com/

    But again, this only takes me to the second page, where the message "Insert password" is written in red letters.

    This is the setting leading to this result:

    Could you maybe check if you have different values in those corresponding boxes? (Except for the mail address and password, of course :) )

    Maybe I can replace them manually with your values and get a working result.

    I wonder if it's due to my somewhat aggressive privacy settings in Firefox 37.0.2 (I'm using Windows 7, 64 bit version, btw).
    I want the browser to tell sites I that I do not want to be tracked, and to clear my Firefox history as well as all cookies whenever I close Firefox.

    Could it be that it's due to those settings that 1Password can't autofill-in the forms, even though I have followed your instructions carefully?

    Either way, it's incredibly cynical that Gmail has its users jump through all those hoops in the name of "security"...

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @hspielmann, (and others)

    This is going to be a fairly screenshot heavy post as I try to show what I've done at each stage.

    I visit www.gmail.com and get redirected. I enter my email address into the field and then I click on the 1Password browser icon to bring up the 1Password menu. I navigate to Settings > Save New Login... and it should look a little like this.

    I click Save and my Login item in 1Password looks like this.

    Having saved a Login item for the email address I return to my Firefox and click on Next. I fill in my password and uncheck the Stay signed in checkbox. Like before I open the 1Password menu and navigate to Settings > Save New Login.... This time I change the menu option from Create new Login to Replace account.google.com and I leave the checkbox titled Replace password only unchecked. It should look a little like this.

    I click Save and my Login item in 1Password now looks like this.

    With this item, if I return to a clean copy of the first login page for google I can use ctrl + \ to first fill in my email address and then on the second page have it fill in my password and properly set the checkbox.

    For comparison, I'm running Windows 7 with Firefox 38.0.1, v4.3.1 of the 1Password Firefox extension and version 4.5.0.572 of 1Password for Windows.

    I don't believe aggressive privacy settings should be affecting this at all because 1Password simply stores the contents of editable fields on the web page and as long as you can manually log in, 1Password should be able to fill.

    Hopefully this helps but if it doesn't please do let us know.

  • edited May 2015

    Confirmed NOT working under OS X 10.10.3, 1Password 5.3 :-(
    I realize this change has been initiated by Google (guilty of change for change's sake), but we have multiple Google Apps domains, and hence this is a key feature (for us) of 1Password.

  • brentybrenty 1Password Alumni
    edited May 2015

    @barkingseal: Well...I just logged into Gmail with one of my Google Apps accounts using the same OS X and 1Password versions. Which browser version do you have? If you're able to share the specific URL where you seem to be having trouble that may help shed some light on this too!

    While I'm not a fan of the way that Google does multiple logins, as far as I can tell, nothing has changed. Is Google giving different login pages based on location? :dizzy:

  • I have found that using the URL

    https://accounts.google.com/ServiceLogin?service=wise&passive=1209600&continue=https://mail.google.com

    will use the login page with two fields. Not a long term solution, but good to know.

  • edited May 2015

    @littlebobbytables

    Thanks, I can confirm that I had done what works in your case -- and that it's still not working. The login item that is generated is roughly identical to yours, with two minor differences:

    • The PersistentCookies box is unchecked in my case (certainly because of my browser configuration)
    • the box "lang-chooser" does not show up in my case (since my brower's default language is German)

    Neither of them should have too much of an influence on the login, though.

    The only thing that I had not tried is using the keyboard shortcut ctrl + \ on the first page, the way you described it.

    There is a problem, though: The reason I can't do so is that on the (Swiss) German keyboard layout, \ has no dedicated key. (In fact, the corresponding key, situated between Enter and Backspace, does simply not exist on the standard keyboard around here.) Instead, \ is a tertiary function of the < > key, which can only be triggered by pushing down ctrl + alt + < at the same time.

    If I'm not mistaken, then, this simply renders impossible the task of using ctrl + \ as a shortcut.

    Which begs the question:
    Is there a way to change shortcuts in 1Password?

    ...that said, this still seems to be a workaround rather than a final solution.

    I'll temporarily opt for the URL @Xe997 provided, which is working on my browser -- even though heaven knows when Google will render this inaccessible in the name of security, too.

    I'd highly encourage 1Password to look into a "real" solution for that kind of "split input" -- it stands to fear that other services will copy Google's frankly horrible idea in the not-too-distant future...

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @hspielmann,

    While you can change the keyboard shortcut (it can be found in 1Password's preferences in the Logins tab) I tried logging in by just clicking on the 1Password Firefox extension icon and that worked too.

    I've been re-reading the thread and I now realise I've misunderstood something and compounded the error with certain phrasing. I now see that in your first post you mentioned filling in the email address but not the password - looks like I had a small brain fart when I first read your post.

    With google now using a 2/3 stage login process (3 if you use 2FA), you can't log in any more using a single fill command issued to 1Password. This is how 1Password behaves with every site that uses a multi-stage login, you have to issue the fill command to the first page and then again on the next page. Now if that isn't working we still have a problem to address.

    Is it the case that my misunderstanding is the issue?

    Just as an aside, you might find this page interesting, Using keyboard shortcuts. I found it looking for the Logins tab page and it has some handy shortcuts listed.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @barkingseal,

    I first tested my own gmail Login items in Mac before the discussion turned to Windows. Like Brenty they worked for me without alteration. I wonder if my possible realisation regarding the troubleshooting with hspielmann applies here too?

    Is the issue that the fill command needs to be applied twice, one per page or is it that after attempting to fill that it doesn't on one of the pages?

  • edited May 2015

    The issue is indeed that the 1Password command needs to be applied twice, as there is now 2 pages. I can issue the command twice (once per page) and I'm logged in, but this what I'm trying to avoid.

    This DOES vary based on URL, ie: admin.google.com still provides BOTH fields on a single page, while mail.google.com, does not.

    Issue persists, verified on Firefox 38.01, and Chrome 42.0.2311.152

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @barkingseal,

    It would seem possible that the popularity of Gmail means how we behave with multi-page logins will become evident to a larger percentage of our user base. Obviously it will depend on your perspective but how 1Password interacts with google's new login page isn't considered broken, this is how we've always dealt with multi-page logins (to the best of my knowledge). Now that isn't to say that it couldn't be improved, just this isn't a bug.

    So this behaviour will be observable regardless of the browser and indeed platform. What I can do is place a feature request regarding this but I can't make any promises as to if such a feature will added and if then when.

    ref: OPX-998

  • brentybrenty 1Password Alumni

    I have found that using the URL https://accounts.google.com/ServiceLogin?service=wise&passive=1209600&continue=https://mail.google.com will use the login page with two fields.

    @Xe997: Thanks for sharing that! While I haven't had trouble with Google's new login format yet, I'm totally filing this URL away in case I do.

    Is anyone else able to confirm that using this particular URL helps?

  • My old URL don't seem to work anymore. It pointed to Google Drive, followed by a redirect to Gmail. Looks like Google Drive now uses the new login page. Google News still uses the old one, so this URL works:

    https://accounts.google.com/ServiceLogin?service=news&passive=1209600&continue=https://mail.google.com

  • brentybrenty 1Password Alumni

    @Xe997: Yeah, those redirects do tend to break over time as they shift things around, unfortunately. :(

    Weirdly I'm still not seeing this issue logging into any Google services. But as things progress, it sounds like this will just be another case where creating multi-page logins can be useful. Thanks again for your help! :)

  • cage123aucage123au Junior Member

    While this is not ideal, I just click twice. Once at Page #1 autofills the username, then when at Page #2 click again for autofill the PW. Like I say, not ideal, but no fiddling about either with scripts, different login sites etc. Hopefully they will fix soon. I am of course doing this from the 1Password icon from the task bar in Safari for my case.

  • brentybrenty 1Password Alumni

    While this is not ideal, I just click twice.

    @cage123au: Better yet, ⌘ \! :pirate:

    Like I say, not ideal, but no fiddling about either with scripts, different login sites etc. Hopefully they will fix soon.

    Unfortunately websites spreading login forms across multiple pages isn't something 1Password can 'fix', but we'll certainly look into ways of automating this in the future.

    However, any logic we may imbue 1Password with to deal with situations like these will probably require fiddling with the Login item itself, since we wouldn't want 1Password assuming, by default, that all logins are multi-page. :dizzy:

  • @Xe997 Thank you very much for your tipp. My solution for multiple Google Accounts works perfectly again. Might be interesting for somebody out there: danielsetzermann.com/mac/solution-multiple-google-accounts-1passwords-fill-submit-feature/

  • littlebobbytableslittlebobbytables 1Password Alumni

    :smile:

  • iPassword will not work with multi page login, I have to use the URL with the double fields single login page. Thank you.

  • ian_ian_
    edited June 2015

    Having recently had to log in to Google accounts more frequently, pursuing a consistent resolution to this topic (logging in to multiple Google accounts without remaining logged in) has been taking up far too much of my time. Like most others here, I suspect, I can't just let these things go. Here are a few observations from my experience:
    (OSX 10.10.3; Safari 8.0.5; Firefox 38.0.5; Chrome 43.0.2357.130; Windows 8.1; Internet Explorer 11.0.9600.something)
    1 I had inconsistent success creating a new login after just completing the field entry - often no dialog box appeared - maybe my system somehow, as a fair amount of quitting/restarting applications seemed to address this.
    2 Tempted to follow the helpful guide from @danielset, but felt that two-page login will eventually be implemented throughout the Googleverse, so decided to grasp the nettle now rather than later.
    3 When I tried following the guide that @brenty links to today, it worked as advertised. Yesterday, it didn't (I was following the steps above from @littlebobbytables but I think they are the same).
    4 Having successfully recorded a pair of logins in Safari, they worked in Firefox, too. As expected, do I hear? Well, they didn't work in Chrome. (Error: This web page is not available. The web page at https://accounts.google.com/ServiceLoginAuth might be temporarily down or it may have moved permanently to a new web address.)
    5 All the Google login pages, as far as I could tell, that require 2-page data entry in OSX browsers, have old-style two fields on a single page logins in Internet Explorer (in Windows, of course).
    6 Despite using 1Password for years, I'd never used Cmd-\ so thanks for that!

    So, for me, part of the problem with this issue has been that I had inconsistent experience repeating the same sequence to record a login; behaviour across browsers is inconsistent; I found a number of other forums/threads before I found this one. I don't think I want to know about iOS and this issue just yet. I need to do some work! All of this could be user error, my computer, etc.

    The issue/error that I describe with Chrome does seem to be a new point. Forgive me for the rest - I don't suppose it's much help to anyone, but you never know.

  • littlebobbytableslittlebobbytables 1Password Alumni

    I've done a bit more testing and I thought I would share my results.

    Here is my environment:

    • 1Password 5.3 for Mac (MAS)
    • Safari 8.0.6 with 1Password Safari Extension 4.3.1
    • Firefox 38.0.5 with 1Password Firefox Extension 4.3.1
    • Google Chrome 43.0.2357.130 with 1Password Chrome Extension 4.3.1.90

    I tested two Login item types.

    1. A basic Login item using https://accounts.google.com/ServiceLogin?service=mail for the website field. When a refer to a basic Login item I mean a blank one created from within the main 1Password window with no knowledge of the website.
    2. A Login item created by following our Using 1Password with login sequences split across multiple pages guide.

    The following were tested with both Login item types and with type 2. I went as far as creating separate items per browser to check for browser specific inconsistencies.

    open and fill from 1Password mini.

    1. Safari. Opens URL in new tab, fills in email address and continues to password screen. ⌘\ fills in password and attempts to sign me in.
    2. Firefox. Opens URL in new tab, fills in email address and continues to password screen. ⌘\ fills in password and attempts to sign me in.
    3. Chrome. Opens URL in new tab, fills in email address and continues to password screen. ⌘\ fills in password and attempts to sign me in.

    Visiting https://www.gmail.com in browser and filling with ⌘\

    1. Safari. Fills in email address and continues to password screen. ⌘\ fills in password and attempts to sign me in.
    2. Firefox. Fills in email address and continues to password screen. ⌘\ fills in password and attempts to sign me in.
    3. Chrome. Fills in email address and continues to password screen. ⌘\ fills in password and attempts to sign me in.

    I found only two issues in my testing.

    1. If keyboard focus is in the Firefox or Chrome address bar when you use open and fill you will not transition to the password page. Either ensure focus is not in the address bar or use open and fill from another tab that isn't viewing https://accounts.google.com
    2. After so many tests I'm now bombarded with captchas as Google thinks I'm up to something dodgy.

    When I have time I shall report back on Windows as well (and iOS if there is interest). Please note that all do require the use of ⌘\ twice, once per page. This is a design decision and not a bug with just Google's login page.

    So @davidh84, I would disagree that 1Password will not work with multi-page logins. It may very well be something specific to your setup is causing you troubles but the testing above indicates we have consistent cross-browser support for Google's Login page. We'll happily work with you to figure out why yours differs from our experiences but we will need a bit more information. I would recommend trying either of my approaches above and see what success you have there.

    Hi @ian_, I'll have to verify if there are any differences between my steps detailed above and those in the multi-page login guide for Windows. You should be finding consistent behaviour over browsers in OS X but given your cross-platform environment I will need to do some more testing before I can say with more certainty what you should be seeing. Personally I would hope that items created on OS X behave in the same manner in the same three browsers regardless of the operating system as both 1Password for Mac and 1Password for Windows are now using the same filling logic. The one exception is Internet Explorer I'm afraid and that will definitely require additional testing. I'd edge towards believing the error with Chrome was a temporary or cache related glitch but I will investigate.

  • Hi @littlebobbytables. The problem I was consistently having yesterday - creating account logins using Safari and using them in Safari and Firefox (successfully) and Google Chrome (unsuccessfully) - has not been repeated today, on another machine sharing 1Password data and using the same applications. So I'm going to presume, at least while I can, that you've correctly identified it as a cache glitch.

    Thanks.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @ian_, caches do serve a purpose but when they hold corrupted data, and I mean this comment in a much wider sense than just 1Password, it's a pain. It's so easy to forget it could be that and you're left cursing a site. If this hunch is right then this page, Delete your cache, history, and other browser data, may be of interest :smile:

    Let us know how you get along though, if you're still having troubles we do want to help.

This discussion has been closed.