Which version for Mac OS 10.8.5?

Options
romad
romad
Community Member

I'm baack!

OK, I just updated my iMac from Mac OS 10.7.5 to 10.8.5. I've been running 1Pwd4Mac 3.8.22 on the iMac and 1Pwd Pro 3.7.2 on my iDevices. Will these continue to work under Mac OS 10.8.5? I'm particularly concerned about WiFi syncing as I have an iPhone 3GS with iOS 6 that I use as a backup to to my iPhone 6.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • littlebobbytables
    Options

    Greetings @romad,

    1Password 3 for Mac does work in Mountain Lion (OS X 10.8) although you might find one or two features are no longer functioning. I know at least on Yosemite that importing is broken because the library we used was changed. What I'm unsure of is exactly when this changed. Most functionality will continue to work though. Now you could upgrade to 1Password 4 as it does run on Mountain Lion but if you need to use Wi-Fi Sync with 1Password Pro on an iOS device that can't be upgraded then you will need to keep 1Password 3 for Mac no matter what. The reason is a lot changed in 1Password 4 including fundamentally how Wi-Fi Sync works and so version 3 cannot Wi-Fi sync with version 4.

    Now you could set it up so that 1Password 4 for Mac syncs your vault via Folder Sync and just use 1Password 3 for Mac for Wi-Fi Syncing - we have a few people that have done that in the past but it's up to you. As 1Password 4 is a paid upgrade over 1Password 3 you may decide to stick with 1Password 3 for a little longer. If you do decide to upgrade though please note you can use your 1Password 3 licence key to obtain a 50% discount if you purchase from our AgileBits Store. What you're purchasing is actually a 1Password 5 licence but it does allow you to run an older version if needed.

    One thing of note is that recently Firefox removed something called the widget module. Our extension used this so as of Firefox 40 our 1Password 3 Firefox Extension no longer works. 1Password 4 uses our newer (and current) extension so it isn't an issue there. For the options available 1Password 3 extension missing in Firefox 40 or later will cover everything.

    Hopefully that helped a bit but if you have any follow up questions or feel I haven't answered something well enough please do say and we'll do our best to correct that :smile:

  • romad
    romad
    Community Member
    Options

    Thanks for the warning vis-a-vis FF40. I'll have to remember to never go past 39 if I have to stay with 1Pwd3. Actually the reason I still have a 3GS as my back up is because I lost my iPhone 5 in May 2014 and had to buy an iPhone 6 in October. Otherwise, the iPhone 5 would have become a backup. Using the 3GS from May to October 2014 was a little painful so I can imagine what it would be like if I had to use it instead of the 6.

  • littlebobbytables
    Options

    Greetings @romad,

    One possibility is to not upgrade past Firefox 39, however we're kind of tending towards Firefox ESR 38 which we cover in that link. The benefit of the ESR branch over the regular one is that Firefox ESR 38 will get security updates through to approximately May of next year but only security updates. That way you can feel safe without surrendering access to the 1Password 3 Firefox Extension. It would give you time to decide how you wish to proceed and maybe your situation will have changed at that point.

    If you have any other questions at all please do ask :smile:

This discussion has been closed.