Extension will be outdated in Firefox 57 [version 4.6.9 extension is WebExtension compatible]

LosInvalidosLosInvalidos Junior Member
edited August 2017 in 1Password in the Browser

So Firefox 48 is starting to roll out e10s for end users. When e10s is enabled the 1P browser extension for FF no longer works. This is a known issues at least for over 2 years as of this post:

Browser extension does not work with multi-process Firefox (e10s) on OS X

What's the current status as this will be the default in FF.

1Password Version: 6.3.1
Extension Version: 4.5.8
OS Version: 10.11.6
Sync Type: -



  • MeganMegan

    Team Member

    Hi @LosInvalidos,

    Thanks for bringing this to our attention! I looked into the thread that you mention, and it appears that the issue as reported there was resolved on Firefox’s end in 2015, so we might be looking at something different here.

    Could you tell me bit more about what you’re seeing and what “it doesn’t work” looks like? For example:

    • Does clicking on the browser extension not bring up the interface?
    • Does 1Password fail to fill?

    The more detail you can provide, the better we’ll be able to track this down! :)

    ref: OPX-555

  • LosInvalidosLosInvalidos Junior Member
    edited August 2016

    Sorry for the fairly unspecific report. That wasn't too useful. Here go the details:

    • Keyboard shortcut to fill logins on a page that's already loaded are working
    • clicking a 1P bookmarklet in FF with e10s enabled in FF 48 (or in 51a1, which has e10s enabled by default) does not work

    A really tiny moment after the bookmarklet is clicked, the loading spinner can be seen on the tab but then nothing happens. So to reproduce e.g. open a new tab and click any 1P bookmarket. So there are severe issues with e10s enabled in Firefox (stable, beta and nightly).

    Let me know if you need further detail.

  • MeganMegan

    Team Member

    Hi @LosInvalidos,

    Thanks for those details! I’m wondering if a Diagnostics Report will shed any light on what’s happening here.

    I'd like to ask you to create a Diagnostics Report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • LosInvalidosLosInvalidos Junior Member

    Before doing that, may I ask, if you have tried to reproduce the problem and what the outcome was.

  • e10s is a new performance feature in Firefox that was just released in version 48. AgileBits was notified that the Firefox browser extensions is not compatible at least 2 years ago. I'm very disappointed that it has not been updated for e10s support.

    If you open Firefox, and type in about:support into the URL bar, you'll see that "multiprocess windows" is disabled. This is because the 1password Firefox extension is not compatible with e10s- and so Firefox completely disables e10s.

    You do not need any diagnostic data to recreate this issue. Install Firefox 48, install the latest 1password extension, type in about:support, and see that e10s is disabled.

  • khadkhad Social Choreographer

    Team Member
    edited August 2016


    Electrolysis is not enabled by default for everyone in Firefox 48, so it not being enabled doesn't necessarily indicate anything. From Asa Dotzler's bog post:

    (When we hit release in about six weeks, not all of our Firefox 48 users will get E10S. The teams have been working really hard but we’ve still got some compatibility and other work to do to make E10S ready for everyone. The groups that will have to wait a bit for E10S account for about half of our release users and include Windows XP users, users with screen readers, RTL users, and the largest group, extension users.)

    According to http://arewee10syet.com/ (linked from https://wiki.mozilla.org/Electrolysis):

    e10s is enabled by default in Firefox Nightly, but disabled in Firefox's other release channels: Developer Edition, Beta, and Release. When e10s is enabled, Firefox's tab tool tip is suffixed with "- e10s".

    Mozilla fixed a problem related to this on their end over a year ago:

    Bugzilla: Bug 1042195 - (e10s-1password) 1Password Extension does not work with e10s

    And indeed, 1Password works fine for filling on pages in Firefox with Multiprocess Windows (i.e. Electrolysis) enabled. I am using it myself.

    The only thing not working seems to be an old feature we used to call 1-Click Bookmarks. To be honest, I'm not even sure of the status of 1-Click Bookmarks. It's not possible to create new ones in the current version of 1Password for Mac. I'm going to check on that.
    ref: OPX-1221

  • Yes, the problem seems to be the not-working 1-Click Bookmarks.

    1Password still works and fills out e.g. a login form in Firefox with multi-process enabled. But for this, the website with the login screen has to be already open.

    I use 1Password normally together with the app Alfred on a Mac for a fast and convenient way to open a website with a login. For this, Alfred has access to the urls within 1Password and you save a lot of typing or bookmark search.

    With multi-process Firefox, this does not work anymore. The url is entered into the browser, but the page is not loaded and remains white with the loading spinner shortly visible as described by LosInvalidos. The master-lockscreen of 1Password also does not appear. Even clicking the relaod-button of firefox does not bring up the page.

  • Hi guys,

    I wanted to chime in about the use of these bookmarks for third parties.

    Khad said:

    The only thing not working seems to be an old feature we used to call 1-Click Bookmarks. To be honest, I'm not even sure of the status of 1-Click Bookmarks.

    Alfred generates 1Click bookmarks from the bookmarks-default.json file created when a user checks the "Enable 3rd party app integrations" box in the Advanced 1Password preferences. This is how users can search for their 1Password bookmarks in Alfred, and launch them in their default browser.

    Once Alfred tells OS X to launch the bookmark in the default browser, it's up to the browser and 1Password to log the user in, but for that initial bookmarks search, Alfred (and other third parties) do need the 1-Click bookmarks file generated for integrations.

    Vero (From the Alfred team)

  • gbue said "1Password still works and fills out e.g. a login form in Firefox with multi-process enabled." As soon as I enable the 1password plugin on Win10 or OSX, Multiprocess Windows disables itself with the reason (Disabled by add-ons). How did you get around this?

  • Hello tivrick,

    to enable multi-process in Firefox 48 first check with about:support, if multi-process is enabled or not. If not, enter about:config and set the following variable

    browser.tabs.remote.autostart = true

    Restart Firefox and check again, if multi-process is enabled. If it's still not, enter the config-mode again and add the following variable

    browser.tabs.remote.force-enable = true

    Restart Firefox again. Now multi-process should be enabled (tested on OSX).

  • littlebobbytableslittlebobbytables 1Password Alumni
    edited August 2016

    Hi @LosInvalidos, @robbyt, @gbue, @VeroPepperrell & @tivrick,

    I've mentioned you all in this reply because I've moved the thread to our filling and saving section of the support forums.

    There are three ways to fill, each different in the path they follow in terms of code and they are:

    1. Fill the currently loaded page. This can be done either via the Command-Backslash (\) keyboard shortcut or selecting a Login item that 1Password has matched to the current page when the 1Password mini menu is visible.
    2. Searching for a Login item from inside 1Password mini and selecting one from the matches found. This looks like open and fill in the sense that by default it opens a new tab at the specified URL and then fill after the page has loaded.
    3. What we call open and fill. This is either when you click on the URL stored in a Login item or make use of a 1-Click bookmark. 1-Click bookmarks are literally just the URL 1Password passes to the browser when you use open and fill which is how they work.

    The reason for detailing each is you should all find filling via either 1. or 2. works regardless of the status of e10s. This leaves open and fill/1-Click bookmarks. e10s is a big change for Firefox and everything that the old approach allowed is not mirrored. One key piece of functionality that we've not found a replacement for was the ability to monitor the URL that is about to be loaded. We use a listener to that grabs the URL before the browser does anything with it. If we find the 1Password specific parameters, we recognise it as requiring filling after it has loaded. We remove the parameters (they were only for us) and then let the browser actually load the real URL. Due to how e10s does things differently this isn't currently possible like it used to be.

    One of our senior developers has some ideas here but it's unlikely there will be a quick fix, instead we're likely looking at a reasonable change to how it all works so we can bypass needing to check the URL prior to loading. If we need to go down this route it may mean problems for 1-Click bookmarks as that's all about passing the URL. Nothing is concrete right now so we'll see what happens. For the moment though if e10s is enabled it means open and fill/1-Click bookmarks won't.

    Just to clarify, the previously reported issue was that early on in the life of e10s, something broke the extension completely. The issue here is a different one, limited to the one form of filling.

    Does anybody's experiences differ at all from what I've described? If they do please let us know and I'm sorry we don't have a more positive answer to give at the moment.

  • LosInvalidosLosInvalidos Junior Member

    Accurate summary matching what I found in my initial report.

  • AGAlumBAGAlumB 1Password Alumni

    Thanks for confirming! Hopefully we'll be able to find a solution in the future.

  • @littlebobbytables

    Thank you for the summary. Just to confirm:

    1. works
    2. works
    3. does not work. Neither by clicking the url in the 1Password login item, nor with 3rd-party-apps like Alfred on Mac.

    Hope you will find a solution to make 3. work again. Thank you!

  • AGAlumBAGAlumB 1Password Alumni

    Indeed, we'll see what we can do! Thanks for your patience and understand while we work on this problem. :blush:

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    To follow up on what Brenty said, I would like to add that the APIs we use for processing open and fill from the main app and 1Click bookmarks are not e10s compatible and from the Bugzilla activity, it does not look like any work is going to be done to make this happen.

    Firefox is moving to WebExtensions, though, and that API is multi-process from the start. Right now, there are some obstacles for us to get around before we can move our extension from the current Firefox add-on SDK to WebExtensions. Mostly, this centers around the mechanism that 1Password uses to connect from Firefox to 1Password mini/helper. There's quite a bit of work left for us on that front, and the API we plan to use for this will not be in stable Firefox until November at the earliest.

    I hope that makes some sense and explains where we are at this time.

    Jamie Phelps
    Code Wrangler @ AgileBits

  • Firefox is moving to WebExtensions, though, and that API is multi-process from the start. Right now, there are some obstacles for us to get around before we can move our extension from the current Firefox add-on SDK to WebExtensions. Mostly, this centers around the mechanism that 1Password uses to connect from Firefox to 1Password mini/helper. There's quite a bit of work left for us on that front, and the API we plan to use for this will not be in stable Firefox until November at the earliest.

    That's a little surprising to me. In terms of development and release, I would have thought Mozilla would roll out e10 with WebExtensions together. While e10 is not enabled by default, they are slowly enabling it for users in a staged rollout. It would seem to me that with so many extensions on the old API, they would only enable it by default once WebExtensions is released as well.

    I've been using Chrome to get by as I was patiently waiting for e10 to reach stable. This news is a little bit of a bummer as it means a few more months of waiting. Thank you all for the informative post.

  • AGAlumBAGAlumB 1Password Alumni

    @alamarco: Who knows? Maybe that was part of the plan originally. Nothing ever goes according to plan. :lol:

    But yeah, that could pose a problem depending on the timing. I guess we'll just have to wait to see how it plays out. They aren't as fully-featured (and sometimes that's a plus), but there are some solid alternative browsers out there now too. Cheers! :)

  • I'm on Firefox 49.0.1 with e10s enabled on macOS sierra 10.12. When I click the 1Password icon in Firefox I get a page saying "
    Looking for the 1Password app" and nothing else. This totally breaks my workflow. :-( Is there anything I can do short of disabling e10s?

  • AGAlumBAGAlumB 1Password Alumni

    @RichieB: It sounds like you're saying that 1Password isn't able to connect to the extension in Firefox at all. Is that the case? Does disabling e10s allow 1Password to work again? Are you seeing different behaviour than what lil bobby summarized earlier in this discussion? Let me know what you find!

  • After I posted in this thread I noticed the same thing happened in Safari (error message and no communication with 1Password app). I rebooted my iMac and everything works again. So weird.. never had this type of issues in years (since switching from Windows to OS X).

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @RichieB,

    There are a couple of possibilities as to why a reboot helped. We've noticed that things don't always get shut down properly when updating 1Password from the App Store but this only affects Mac App Store customers. It may be something else killed the 1Password mini process and a reboot would have resulted in a fresh instance starting up. Let us know if you see the weird behaviour return as maybe the reboot is masking an issue rather than fixing a one-off blip.

  • I did test 1Password mini (from the macOS menu bar) before the reboot and it worked fine. It was just the browser plugins that had a problem. I'll let you know if it returns.

  • littlebobbytableslittlebobbytables 1Password Alumni


  • No it was on my iphone and my Mac. I tried rebooting. Nothing helped

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @lankiloo,

    Did you mean to post in this thread? your post sounded like a reply but I'm unsure who you might be responding to.

  • I'm having related issues. Mac OS Sierra, Firefox 49.0, 1Password 6.3.3, 1Password Extension 4.6.1.

    After starting Firefox, I often get a page saying "looking for browser extension". The extension works, I just get this page anyway and just close it.

    In either case, I googled it and found this thread. My Multiprocess Windows is "Disabled by add-ons", but I don't know which of 7 is doing that. Will have to experiment to figure it out.

  • AGAlumBAGAlumB 1Password Alumni

    @stevefal: It sounds there may be a few issues at play. First, you're using the latest 1Password extension which supports the new mutual authentication, but it looks like you haven't yet updated 1Password itself. Be sure to check for updates first. Which add-ons are you using? Maybe we can help narrow it down! :)

  • I've updated 1Password and so far haven't seen my original issue. Thanks.

    As far as extensions, I'm using 7, and only one allows Multiprocess Windows to be enabled:

    MP enabled
    uBlock Origin

    MP disabled
    FB Purity
    Google Search Link Fix
    Self Destructing Cookies
    Tree Style Tab

    I determined these by disabling all, and then enabling each, alone, with a restart of FF for each test. uBlock Origin is the only add-on of mine that allows Multiprocess Windows, and it does reliably.

  • Just FYI:

    With the latest update I was only able to make the 1password extension working by disabling:


    and quitting and restart FF for the extension pairing.
    After that I could enable the settings again and restart FF, seems to work again.

This discussion has been closed.