Where did my attachments go?

jbaranickjbaranick Junior Member

Ever since moving from 1Password with Dropbox syncing to 1Password for Teams/Families, all attachments are marked as deleted and they are separate items. This makes it really hard to find my attachments.


1Password Version: 6.5.3
Extension Version: 4.6.2
OS Version: OS X 10.12.3
Sync Type: 1Password for Teams/Families

Comments

  • PilarPilar

    Team Member

    Hi @jbaranick

    Thank you for taking some time to contact us. The way attachments/documents actually changed in 1Password accounts and now instead of attachments to any items you have a category for "Documents" in general. It sounds like you liked the way it used to work better, I'll be sure to let our developers know and we might consider having attachments again instead of documents :chuffed:

    I'm very sorry for any inconveniences you've had with all this!

  • jbaranickjbaranick Junior Member

    I don't really prefer one way of the other, but when you migrate from the old way to the new the attachments should remain linked. Right now the original time just says they the attachments have been deleted, but I can go and find them and link them back up. You should be doing this automatically, as this would reduce headaches while migrating and likely solve most issues around this.

  • PilarPilar

    Team Member

    Hi @jbaranick

    Thank you very much for your feedback! I'll let our developers know and I hope that we can implement this into 1Password some day to make it all easier for you :chuffed:

  • Drew_AGDrew_AG 1Password Alumni

    Hi @jbaranick,

    I wanted to add that what you've described isn't the expected behavior, so I'm not sure why that's happening. When you move or copy an item that contains an attachment from a local vault to a 1Password.com account vault, the attachment becomes a separate Document item, and the original item should have a link to that Document under the Related Items section. It should look very similar to an attachment, but it's really a link - when you click on it, it will open that Document item.

    I don't know why the original item would show "(deleted item)" instead of a link to the Document. The only way I can reproduce that is if I purposely move a Document item to the Trash and then empty the Trash. It sounds like your attachments still exist as Documents items, though. So I don't know what might have happened, but as Pilar said, we'll let our developers know so they can take a look and see if there's a bug somewhere. Do you happen to still have a local/Primary vault? If so, I'm curious what happens if you create a new item in Primary, add an attachment, and then move the item to your account vault. (But if you no longer have a Primary vault, that's fine.)

    We really appreciate that you took the time to contact us about this! If you happen to run into more problems with attachments/Documents, please let us know. Cheers! :)

  • jbaranickjbaranick Junior Member

    Thanks for taking this seriously. I don't have a local vault anymore. This is a completely new computer. I manually went through my items and linked them up, but it would be nice for this to not happen.

  • RomanRoman 1Password Alumni

    @jbaranick - Agreed! And as Drew pointed out earlier, this isn't expected behavior at all. Let's see if our developers find anything. Thanks for bringing this to our attention and providing detailed information. Appreciate it! :)

This discussion has been closed.