OSX Sierra (Touch Bar/ID) keeps asking for Keychain "Local Objects"

On my new late 2016 Retina 13,3 MBP with Touch Bar and Touch ID I have serious trouble with recurring prompts to type in my OSX User Password in order to use 1Password (for example). So, if I want to login to a website, be it Chrome, Firefox or Safari (all with the latest extension version), initially I have to type in my User Password when pressing the combination for Auto-fill.

I already tried the often-mentioned solution of deleting that OSX Keychain in order to rebuild it with no luck. Had to erase and rebuild my fingerprints afterwards. If a dialog with Touch ID comes up, it does work. I don't save any passwords in any browser. So, the described behaviour only shows up in combination with 1Password.

Any ideas here what to do to get rid of that asking?

Thanks,
thomas


1Password Version: 6.5.3
Extension Version: latest
OS Version: 10.12.3
Sync Type: Dropbox

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @stupid_man_suit,

    Sorry to hear you keep seeing that prompt for your macOS user password! We've heard a few similar reports, and so far it seems to be related to small issues in the operating system. We'll be happy to help figure out what's causing that.

    Thanks for mentioning the suggestions you've already tried. I found another forum thread for a similar issue, and that customer was able to find another solution: https://discussions.agilebits.com/discussion/comment/345290/#Comment_345290

    Can you please try that to see if it helps? Let us know how it goes, and if it's still a problem, we'll continue from there. Cheers! :)

  • Hi @Drew_AG, thx for coming back to me. I'll have a look at that thread.

    I want to add further information on my behaviour: When my Mac was on standby and I use 1Password to auto-fill then, I get the disturbing password prompt from OSX. After putting in my password I have to use Touch ID to finally auto-fill a login form then. Will update after having looked at the other one.

  • Drew_AGDrew_AG 1Password Alumni

    Thanks for the additional information, @stupid_man_suit!

    I checked with our developers about these issues, and they also believe there's a bug in Sierra which is causing this to happen. They've submitted a bug report to Apple, so hopefully that will help. It's something that can affect Touch ID in general, not just 1Password. Out of curiosity, do you happen to use any other third party apps on your Mac that support Touch ID? If so, are they working correctly or do they give you a similar error?

  • Hi again @Drew_AG, so far I don't use any except for the built-in ones and 1Password, so no further notices on this side.

    I followed the guidance from the other thread — so far this looks good and helpful! Haven't seen the password prompt since. Will watch this and give another feedback in a few days.

    Thanks.

  • RomanRoman 1Password Alumni

    @stupid_man_suit - On behalf of Drew_AG you're welcome. I'm happy to hear that the other discussion seems to have offered a solution to your problem. Please do let us know if you see any further issues! :)

  • Hi @Drew_AG & @Roman, unfortunately I have to revise my feedback. Yesterday, all worked flawlessly, but today, OSX is bugging me again with password prompting. So far, nothing has changed in my OSX — there were no updates, I didn't change anything within 1Password, haven't installed any software etc. Didn't change anything about the OSX Keychains as well — the "Local Objects" one contains only two entries, both called "lock-service", they were created on Tuesday when I deleted that Keychain, before trying the solution from the other thread.

    Any other ideas except for the bug report you've sent to Apple?

    Thx!

  • edited February 2017

    Once again, further information: It seems that there are problems with the unlocking after Screensaver/Standby, still. I have them activated with the option "5 Seconds", nonetheless sometimes it unlocks without me giving a password / using Touch ID.

    Touch ID doesn't recognize my fingerprints correctly even though I've redone them.

    I've attached a screenshot of the password prompt.

    ".. wants to use the Keychain "Local Objects". Please enter password."

  • RomanRoman 1Password Alumni

    @stupid_man_suit - Thanks for giving us additional details on the issue you're seeing. I'd like to ask you to create a Diagnostics Report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • edited February 2017

    Support ID is #UJN-64578-221.

    Additional notes: Without changing anything, again, Touch ID seems to work once again. But, what's strange now — I have to Touch ID myself sometimes again for auto-filling in something, even though 1Password is not locked / Screen/Mac was not locked.

  • RomanRoman 1Password Alumni

    @stupid_man_suit - Thanks, I found your email. We'll look into it and get back to you there! :)

    ref: UJN-64578-221

  • edited February 2017

    Okay, I would really appreciate that as of now, the combination of new MBP, Sierra and 1Password is rather frustrating.. ;-/

    I continue to observe the behaviours — it's all not completely repeatable, but as of now, if I send my Mac asleep or screensaver is coming on, no password at all is being asked for sometimes. Preferences weren't changed and still say "Password needed 5 seconds after.." Keychain prompts come and go, rather randomly.

    Switching Touch ID checkboxes in the System Prefs off and back on sometimes helps, so after doing that, 1PW doesn't prompt to Keychain password but for proper Touch ID unlocking.

    And this Mac was set up fresh without any data migration or TM backup or whatsoever. My main concern is that not 1Password is causing the trouble but Sierra, Keychains and the Touch ID stuff.

  • brentybrenty

    Team Member

    @stupid_man_suit: This is a bit of a long shot, but given that Touch ID/Touch Bar on the Mac use local networking to communicate, we've heard reports of 3rd part software interfering: VPNs, antivirus, etc. If that were happening in your case periodically, it may cause some sort of reinitialization, which in turn may cause the Keychain prompt to come up again. Do you have something like that running on your Mac?

  • @brenty: Nope, not at all I would say — I had NearLock (unlocking via BT if iPhone is nearby) before but don't use it on the new Touch Bar MBP.
    What's running in background is Dropbox (obiously), BetterTouchTool, and that's about it, everything else is OSX.

    What's especially strange: Now today, Touch ID started working again without me de-activating it or deleting once again all my fingerprints and re-entering them. Yesterday it wouldn't work at all, couldn't do anything with Touch ID. This morning, as if nothing was ever wrong.. could simply unlock my MBP after being in sleep over night.

  • brentybrenty

    Team Member

    @stupid_man_suit: Well that's just weird. If it happens again, please generate a diagnostics report, as that may help us identify the issue. Just send it to [email protected] and post the Support ID you receive here so we can cross reference. Thanks!

  • Hi there, I did so: #AXI-92958-122
    Now this morning, I couldn't unlock my Mac with Touch ID (none of the 3 saved fingerprints worked), with the third or fourth try (I think you should see that in the Diagnostic?) I could unlock 1Password.

  • brentybrenty

    Team Member

    @stupid_man_suit: Thank you! We don't get much at all out of macOS when it comes to Touch ID, and if it's happening with macOS itself it may be best to contact Apple. But maybe this will at least offer some clues. Cheers! :)

    ref: AXI-92958-122

This discussion has been closed.