Spotlight does not find the Mac app when I search

I typically use spotlight to find and launch apps on my mac. When I invoke spotlight and type in "1Password" it does not show the application. I have checked my spotlight preferences and everything looks good. I can also find any other apps on my mac this way.

1Password Version: 6.6.4
Extension Version: Not Provided
OS Version: 10.12.4
Sync Type: icloud
Referrer: forum-search:spotlight


  • edited April 2017

    I have this problem too. It started right after the 6.6.4 update from the App Store

  • slproxyslproxy
    edited April 2017

    Thanks. At least it is not just me. Let's see if we can get some guidance from agilebits.

  • brentybrenty 1Password Alumni

    @slproxy, @scottelundgren: Unfortunately there isn't much we can do to help with that. Spotlight is an Apple technology, part of macOS, and we don't have any control over its indexing. This happens to me from time to time but it seems to resolve itself. You may be able to rebuild the index, but I can really only point you in the direction of Apple's documentation on this:

    How to rebuild the Spotlight index on your Mac

    If that doesn't fix it, you may need to contact Apple for assistance. Let me know how it turns out!

  • That seemed to fix it. Thanks.

  • Drew_AGDrew_AG 1Password Alumni

    I'm glad to hear that took care of the problem! If you need anything else, please let us know. Have a great weekend! :)

  • I couldn't trigger the reindexing of /Application folder this way.
    Looking at the spotlight-index it got stuck two weeks ago

    sudo ls -l /.Spotlight-V100 # showed some old dates to the files

    But I was able to reset the whole index with mdutils

    # turn indexing off for the whole drive
    sudo mdutil -i off /
    # turn indexing on again
    sudo mdutil -i on /
    # reindex 
    sudo mdutil -E /

    cheers Kai

  • rudyrudy

    Team Member


    Thanks for the update.


  • A way more simple fix is to add 1Password to the Privacy list of the Spotlight System Preference, close it, and then open the Spotlight System Preference, and remove it from the Privacy list again. After that, 1Password immediately re-appears again.

  • rickfillionrickfillion Junior Member

    Team Member

    Thanks for the simpler workaround.


  • The method shown by Marc_H does not work for me. When I try to add items to the Spotlight Privacy list, all items in my Applications folder, including 1Password are disabled.

    Toy's instructions worked for me in an instant. Thank you.

  • @johnpitchko: I'm glad to hear you were able to find a solution that worked for you! It's great that folks have left so many suggestions in this thread to help others that run into this problem. :+1:

  • CalfeeRiderCalfeeRider Junior Member

    Some funky things are happening on my late 2017 21.5" iMac, running MacOS 10.12.6 (fully updated). One of them is that this morning, Spotlight won't find anything. Another is that sometimes slows to a crawl. A third is that when I tried to configure my Airport Extreme (Time Capsule 3 TB, 802.11ac dual-band with beam forming antennas) to host Back to my Mac connections, the router failed to complete the update and had to be rebooted.

    However, the file-finding capability was relatively simple to fix (though I don't know how it could have happened in the first place). When i checked Spotlight's "Privacy" tab's configuration it was set not to index my primary hard drive!

    I don't know if there are any behind-the-scenes housekeeping activities in MacOS that turn off Spotlight, then turn it back on, but I know that I never did that intentionally. It looks as though the indexes were present, however, because as soon as I removed the boot volume from the Privacy (don't index) list, I was able to find files again instantly.

    Jim Robertson

  • brentybrenty 1Password Alumni

    That's interesting. I'm not sure what would disable that. Thanks for sharing! Perhaps that will help someone else as well. :)

  • Hi everyone,

    I've been experimenting the same issues describe here. Spotlight is no longer able to files and documents. The Mail app is unable to show flagged messages or search through my mailboxes. I was able to verify the issue by reverting my Mac to clean install (using Time Machine) and installing only 1Password. As expected, Spotlight keeps re-indexing and provides only intermittent functionality.

    1Password support, please advise.

  • BenBen AWS Team

    Team Member


    Could you please clarify if this is a problem with 1Password, or is it a problem with Spotlight? Unfortunately we're not in a position to help with the fact that searching in the Apple Mail app isn't working properly or that Spotlight is continuously indexing. That would be something to discuss with Apple directly.

    If there is a problem with 1Password we'd be happy to help.


  • Hi @Ben

    I'm convinced 1Password is interfering with Spotlight Indexing. I verified the issue by restoring my computer to a clean install. I then proceed to download and setup 1Password. To verify the issue I also configured the Mail app. Sure enough, Spotlight keeps constantly re-indexing. I allowed the computer to remain in this state over-night. The issue persisted in the morning. So, as you can see, having only stock Apps and 1Password, Spotlight stops working. The logical conclusion is that 1Password is the culprit.

  • BenBen AWS Team

    Team Member


    I'm not sure I'd come to that same conclusion when you also consider the millions of people running 1Password for Mac that are not having issues with Spotlight. If you uninstall 1Password do the issues with Spotlight persist?


This discussion has been closed.