First Search Result Obscured

Penelope PitstopPenelope Pitstop Junior Member

This happens all the time in my primary vault, but I can't reproduce it in the Demo vault.

When I tap to enter a search term, the search field expands to include the buttons for Search Titles and Search Everything. However, it seems to obscure the first item in the list below.

When I subsequently type a search term that yields the target item at the top of the list, it is scrolled out of view:

Only a minor annoyance that has existed for some time, but it would be great if someone could fix it.

Many thanks

PP


1Password Version: 6.10 (61000001)
Extension Version: N/A
OS Version: iOS 11.1 Public Beta 2
Sync Type: N/A

Comments

  • sjksjk oversoul 1Password Alumni

    Hi @Penelope Pitstop,

    Thanks for reporting this. Looks like the same bug we've got filed in our tracker, basically that a search hides the first item in the results list and displays second item instead … only on devices with 4" displays. So is it happening for you on a device with a 4" display, like an iPhone SE or 5c?

    ref: OPI-4034

  • Penelope PitstopPenelope Pitstop Junior Member

    Hi @sjk

    An iPhone 7 actually.

    This is a bit more subtle than that. Half of the first item in the list is obscured. It's not like it has scrolled perfectly to the second item.

    I hope that helps.

  • sjksjk oversoul 1Password Alumni

    That's interesting, and all this info (which I've included in the previously filed bug) will be helpful to the developers -- thanks!

  • @sjk also seeing the same bug, happening on both an iPhone 7 and 7+.

    Notably the search results need to extend off the screen to trigger it, if the results are shorter then you don’t see it.

    Finally in my case it completely obscures the first result. Spent ages trying to figure out why the hell 1Password had lost one of my logins.

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi ThomasPurchas ,

    Thanks for letting us know. We're looking into it. We can reproduce it here too.

    Cheers,
    Kevin

    ref: OPI-4034

  • Penelope PitstopPenelope Pitstop Junior Member

    Thanks for the fix in the 7.0.4 beta!

This discussion has been closed.