3D Touch and click Search shortcut not working

Bug

  • First open 1Password and select any tab except Categories in Tab Bar. Press home button.
  • 3D Touch the 1Password icon and tap Search icon.
  • Search won't appear. If you're in Categories tab, it'll work.

Is this bug reproducible?
Yes, happens every time.

Which device I am using?
iPhone 8 Plus running iOS 11.1 beta 5.


1Password Version: 6.10 (61000006)
Extension Version: Not Provided
OS Version: iOS 11.1
Sync Type: 1Password Account

Comments

  • MrRooniMrRooni

    Team Member
    edited October 2017

    Thanks for the report, @anmol! I have filed this one in our bug reporter as OPI-4258. We'll take a look and see what we can do to get it sorted out.

    ref: OPI-4258

  • Hey @MrRooni, this is happening again in new build released few hours ago. This is still not fixed. Although it was working in last build, new build broke it again.

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @anmol ,

    Which build are you running, currently?

    Thanks,
    Kevin

  • Hey @ag_kevin

    I am running the latest build 6.10(61000008)

  • brentybrenty

    Team Member

    @anmol: I'm not able to reproduce this on the stable release of iOS using build 61000008. Do you have another device where you're seeing the same thing?

  • MrRooniMrRooni

    Team Member

    Good morning @anmol. I was just able to reproduce this issue.

    Steps to produce

    1. Open and unlock 1Password.
    2. Disable Lock on Exit in Settings > Security.
    3. Select any tab except the Categories tab.
    4. Hit the home button.
    5. Force quit 1Password.
    6. 3D Touch on the 1Password icon and choose Search

    Expected behavior

    I'd be taken to the Categories screen and search would be active.

    Actual behavior

    I'm left staring at the Favorites tab (which is where I left off).

    I will update our internal issue on this one.

  • Hey @MrRooni, the behaviour you just shared is happening for me too. But the bug I reported earlier seems to be fixed. This was happening earlier but I tried it again now and it's not happening! :+1:

  • MrRooniMrRooni

    Team Member

    Thanks @anmol , that means we're getting closer!

  • Yes definitely. :D :)

  • brentybrenty

    Team Member

    :):+1:

This discussion has been closed.