Constantly being asked to type in keychain password.

irvingleeirvinglee
edited January 2018 in Mac

Everytime I unlock or login to my computer I keep getting the following 4 popups: 'sharingd/accountsd/cloudd/cdpd/ProtectedCloudKeySyncing wants to use the "local items" keychain'.

I keep entering the correct keychain password, but it keeps thinking it is incorrect. I've tried changing my user password and then resetting the keychain password and it still doesn't accept my keychain password. It takes forever to keep hitting "cancel" until the popup disappears.

All of these popups has really killed my user experience on my laptop. I'll need a refund if this can't be fixed. Hopefully there is a fix because I really like everything else about 1password!

I'm using 1Password 6 Version 6.8.6 on MacOS High Sierra Version 10.13.2.

Thanks in advance.


1Password Version: 6.8.6
Extension Version: Not Provided
OS Version: 10.13.2
Sync Type: iCloud

Comments

  • rudyrudy

    Team Member

    @irvinglee,

    That's certainly strange, do you happen to have iCloud Keychain turned off? The path you pasted "sharingd/accountsd/cloudd/cdpd/ProtectedCloudKeySyncing" would seem to indicate that those series of Apple daemons isn't able to correctly access iCloud Keychain to do what it needs to.

    Rudy

  • Hi Rudy, thanks for commenting. My iCloud Keychain is indeed turned off. I've tried turning it back on but keep getting the error msg: "iCloud Keychain couldn't be setup because there was a problem communicating with iCloud". I've tried restarting the computer as well.

  • LarsLars Junior Member

    Team Member

    Hi @irvinglee -- rudy is away just now, but this really doesn't seem like a 1Password problem to me. The error message you're receiving is one generated by macOS, not by us, and it doesn't concern 1Password. In looking around for a bit of help, I found this which may be of use to you: https://apple.stackexchange.com/questions/172247/cloudd-wants-to-use-the-local-items-keychain

    Beyond that, however, I'd make an appointment at an Apple retailer near you (if you have one) with the Genius bar. Let us know if there's anything further we can do for you, and good luck with it!

  • roosbekroosbek
    edited March 2018

    I finally got this problem sorted. It's not directly a 1Password issue, but an OS issue that affects 1Password. For me, I think it started when I changed my Mac's password. It wasn't only 1Password asking for a password to the "local items" keychain but random OS daemons like cloudd, sharingd, and even Preview.

    Resolution goes like this...

    1. Open a terminal and run these two commands:
    cd ~/Library/Keychains/
    ls # NOTE: the lowercase l as in Lima, not capital I of India)
    
    1. You should see at least one guid listed like:
      AC7CBB38-19C1-56CB-94BD-A750282BEFAE

    2. Just in case this does affect your system in adverse ways, backup this directory and/or file (I personally had one directory and one file):

    cp -r <directory guid> ~/Desktop/<directory guid>  # NOTE: where <directory guid> is the guid of the directory guid
    cp <file guid> ~/Desktop/<file guid>  # NOTE: where <file guid> is the guid of the file guid
    

    NOTE: You'll know the difference between the two because if you try the second command on the directory, the shell will tell you something like "cannot copy directory" (which then necessitates the -r switch)

    1. Delete the GUID(s) in this directory:
    rm -rf <directory guid>
    rm -rf <file guid>
    

    Reboot your computer and everything should be sorted.

    -Roos

  • LarsLars Junior Member

    Team Member

    @roosbek - Glad to hear you were able to find a solution that worked for you! Unfortunately, I'm not going to be able to add our own recommendation for users to do this, since running destructive terminal commands like rm-rf are a one-way process that has effects far beyond 1Password, and many people may not understand the ramifications of what they're doing. We feel very luck to enjoy the feedback and even pioneering steps taken by a core user community that is quite well-versed in command-line-fu and other magic, but we can't recommend such things for the general user base.

This discussion has been closed.