Bug on 7.0.532 with linked documents

Hello, I'm reporting what I think is a bug. If this is the intended behavior, or if this is not the correct place to bug reports, please let me know.

When I link a document to a login, or anything really, the counterpart link isn't auto created, a little example bellow:

Like I said, I don't know if this is the expected behavior.

Still related with the linked documents but this is most definitely a bug, sometimes when you click on a linked item, it shows the other item just fine, sometimes it redirects you to all items and selects the first of the list.

I think this is happening if the two linked items are not of the same category, like a Software license and a document, and you are not on the list "all items", but on the listing of a specific category on the left panel.

If you need a more detailed description, please let me know.


1Password Version: 7.0.532
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: 1pw cloud sync

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited March 2018

    Hi @rafaelmoreira,

    Thanks for reporting this.

    When I link a document to a login, or anything really, the counterpart link isn't auto created

    This is intentional, Related Items aren't bi-directional by default. You have to link them in both items if you want to establish a bi-directional linkage. When importing your existing vaults, we do link them in both direction and that is only because attachments were attached to the item itself, so they're linked like so.

    We're investigating for a bi-directional related item feature but we have some questions about how it should all work internally, so we're being careful with this at the moment and only allowing one-directional link.

    Still related with the linked documents but this is most definitely a bug, sometimes when you click on a linked item, it shows the other item just fine, sometimes it redirects you to all items and selects the first of the list.

    Good catch, I'll file a bug report and we'll get that fixed.

    ref: OPW-2046

This discussion has been closed.