1Pasword keeps getting locked in Chrome on Windows

Since the last update, the extension in Chrome/Windows has been auto-locking after 10 minutes, ignoring any settings. I even tried disabling auto-lock altogether, and it still locks after a few minutes. Very annoying, since I have to keep typing my password every time I log on to a site.


1Password Version: 7.2.617
Extension Version: 4.7.3.90
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited December 2018

    Hi @quentinv,

    Thanks for writing in.

    Can you double check the list of extensions in Chrome to make sure you only have the regular 1Password extension, not 1Password X?

    Also, is the main 1Password desktop app also locking after ten minutes?

  • Hi @MikeT,

    My apologies, I checked and the regular 1Password extension is installed, but not enabled. I am actually using 1PasswordX, version 1.13.1. The main desktop app does not lock, only the extension.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @quentinv,

    No need to apologize. We at least now know what's the issue is.

    1Password X does not integrate with the desktop app, it's a self-contained 1Password extension that runs within Chrome. So if you close Chrome (last tab), 1Password X would be closed too and thus there would be more locking than usual.

    However, there is some kind of caching issue we're seeing in latest 1Password X update and you can see in this thread.

    It depends on what you want to do;

    1. If you want integration with the desktop app, you have to use the regular 1Password extension instead; to do this, disable or uninstall 1Password X. Then re-enable the regular 1Password extension and restart Chrome.
    2. If you want to use 1Password X, I'll move this thread to our 1Password X forum, so our 1Password X team can help but try to restart Chrome completely if you haven't done so after the update.
  • Thank you. I disabled 1PasswordX and tried using the extension that integrates with the 1Password app for a while, but the UI is so poor compared to 1PasswordX (and some features like filling identities simply don't work), that I switched back to 1PasswordX.

    Luckily it appears that disabling and re-enabling 1PasswordX solved the locking problem, and it now appears to be functioning normally.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @quentinv,

    I'm glad to hear that.

    but the UI is so poor compared to 1PasswordX (

    When you said poor, what do you mean exactly? We will redesign 1Password mini in the near future to be more identical to 1Password X but we won't be able to use the in-field menu, that'll be limited to 1Password X. Better integration with the password generator, modern design and more are coming in future updates.

    (and some features like filling identities simply don't work),

    On all sites? We use the same (outdated at the moment) brain as 1Password X, they fill and save the same way. We'll be including an updated 1Password Brain soon that will have a lot of improvements as 1Password X is more frequently updated than the desktop apps.

This discussion has been closed.