1Password Windows Installation - Important component is missing (Windows 7)

Hi,

I purchased 1Password for Windows today and I can't get it to work. After installation there is this error message "...important component is missing...". I tried some solutions mentioned here in some threads but none of this works. I disabled my AV but this error still remains........

Comments

  • DBrownDBrown 1Password Alumni
    edited March 2014

    What action triggers this error message?

    Also, did you run the installer in an account with "administrator" privileges?

  • This error message comes right after the installation at first start. I installed it as administrator.....

  • DBrownDBrown 1Password Alumni
    edited March 2014

    Thanks, @jmcclane.

    Are you launching the main 1Password program (1Password.exe) or double-clicking on the 1Password.html file in your .agilekeychain folder?

  • svondutchsvondutch

    Team Member
    edited March 2014

    1Password needs the following components. Can you verify they exist on your PC, please?

    http://discussions.agilebits.com/discussion/comment/98465/#Comment_98465

    If one of these components is missing, then 1Password won't start. This is by design. Usually, the cause is a false positive (eg. some anti-virus "solution" mistakenly blocking one or more of these components).

    One more question: are you running SAAZOD by Zenith maybe? This software is notorious for hacking ChilkatCrypt2.dll away from 1Password.

  • I starting 1Password through clicking the 1Password.exe file. I verified that all of these components are there (C:\Program Files\1Password\js3215R.dll, C:\Windows\SysWOW64\ChilkatCrypt2.dll (Windows x64 only) and the registry key). I also disabled my AV while the installation process an I don't run SAAZOD.

  • svondutchsvondutch

    Team Member
    edited March 2014

    @jmcclane is ChilkatCrypt2.dll on your system code-signed by us?

  • In the properties menu (ChilkatCrypt2.dll) I don't have the option to view the digital signature details. But I think I "solved" it. I just deleted the ChilkatCrypt2.dll and reinstalled 1Password. Until now it works fine. So it has something to do with this file........

  • DBrownDBrown 1Password Alumni

    Thanks for the follow-up, @jmcclane. Please let us know if you see the problem again.

This discussion has been closed.