Unable to use backup keychain

Invallid Data File
I recently re-installed snow leopard and took pains to backup my 1password application support folder before doing so. After setting everything up and migrating my preferences and keychains back, everything was working fine - all my 1password information was in it's place.

But then I tried opening it again and it was asking to create a New Data File or Find Existing. I tried importing the version from my local applications support folder and also the file I had backed up before the install. Both files give me the following error:

Invalid Data File
Data File '/Volumes/Archive/>> BACKUP ESSENTIALS/sync - 1 password/~:Library:Application Support:1Password/1Password.agilekeychain' is incorrect or damaged. Please choose another file.


What I don't understand is why it has suddenly stopped working when I was successfully using the application after my re-install. The software versions are the same, i've been able to add my licence, but neither the new or old keychain will give me access to my data.

Am stumped.

Comments

  • khadkhad Social Choreographer

    Team Member
    edited October 2010
    Hi hiredgoon,

    I'm sorry you're having this problem, but welcome to the forums. You have come to a healing place. :-D

    Do you have a copy of your (previously) active keychain? That path looks quite strange if you actually copied and pasted it. Try dragging your 1Password.agilekeychain file to your desktop and double-clicking it there. (This will eliminate any path name oddities.) If that works, you can then move the data file from within 1Password (Preferences > General > Data File > Move…) to Users > [you] > Library > Application Support > 1Password, and you should be all set.

    Please let me know how it goes.

    Thanks!
  • Thanks for the hearty welcome :) I just hope we can fix this issue :unsure:

    The file path quoted in the original thread was from trying to import the keychain from a backup drive. I have followed your instructions and copied the keychain to the desktop. On double click I get the standard "New Data File V Find Existing" window nothing else. It doesn't appear that double clicking is activating the keychain. So, I've tried "Find Existing" and the error message I receive is:

    Invalid Data File
    Data File '/Users/kain/Desktop/1Password.agilekeychain' is incorrect or damaged. Please choose another file.


    I do have an out-of-date sync on my iPhone which I might be able to use if we cannot find a way around this problem. I just do not want to sync in case I lose everything!

    Cheers,

    hg
  • khadkhad Social Choreographer

    Team Member
    By default 1Password stores 50 backups in ~/Library/Application Support/1Password/Backups. If you backed up the whole 1Password folder, there should be plenty of backups. Have you tried restoring from the most recent keychain in the Backups folder?

    Of course, as you suggest, you can always just sync with your iPhone if all else fails, but there should be plenty of options before that. (Although this is probably a very good case for using always on, always up to date Dropbox syncing.)

    Just out of curiosity, what application did you use to backup your data to your external drive?
  • I tried the "Restore data file from backup" and this time it worked (go figure!). So for the moment, it looks like the problem is solved.

    I've been using Time Machine to back everything up as the Dropbox account service I use is shared with a bunch of people and I would not want my private stuff stored in there too.

    Cheers khad. Case closed :)
  • khadkhad Social Choreographer

    Team Member
    Hm. Well, I'm glad everything is working well. Thanks for updating the thread!

    It seems odd that it would suddenly work. I wonder what changed. The world may never know!...
This discussion has been closed.