WiFi Sync Problem

Just bought 1Password for iOS, and tried to Wi-Fi sync to my 1Password for Mac. It failed. I get a dialog box that says "Sync Problem Server error:". When I touch More Info I get this terribly helpful information:

Domain=com.agilebits.onepassword. ErrorDomain Code=7014 "Server error: " UserInfo=0x******** {NSLocalizedDescription=Server error: }

I cannot generate a diagnostic report because when I go into Settings, I have not option for sending a diagnostic report.




  • JasperJasper

    Team Member

    Hi @amandamays,

    I'm sorry that you've been having trouble getting Wi-Fi sync to work properly.

    Wi-Fi sync issues are often caused by firewalls, antivirus software, or network monitoring apps (such as Little Snitch or Hands Off!). If these are not properly configured or uninstalled, they interfere with Wi-Fi sync.

    Another possible cause for this error is a difference in time between the Mac and iOS device. Wi-Fi sync depends on an accurate timestamp from each device, so please make sure both the Mac and iOS device are set use the network's time, then restart both so that the clock does a server check.

    If that doesn't help, please email us a Diagnostics Report from your Mac, along with your forum username and a link to this discussion, to: [email protected]

  • sjksjk oversoul

    Team Member

    Hi Amanda ( @amandamays ),

    We received your email, mentioning that Wi-Fi syncing is working now after using @JasperP's suggestion to get your Mac and iOS clocks synchronized. Thanks for letting us know; he'll be glad to hear that. :)

    If you have any other questions we're here to help!

  • Hey y'all,

    Im having the same problem over here. I've set my phone to auto timezone and my mac to auto and currently they are 6 minutes apart. I restarted the mac, and turn off and then back on my iphone. Any suggestions?

  • JasperJasper

    Team Member

    Hi @cmelious,

    Sorry to hear about the trouble.

    Are both your Mac and iPhone connected to the internet?

    Which one of the devices has the wrong time?

  • Yes, both are on the same wifi, although I'm not certain if the phone gets it's time from the aifi or the cell tower. It would appear the mac is ahead though. Can I simple set it to the same time as the phone?

  • Welp, I tried just that, I set the mac clock to the same thing as the phone and bingo, it worked. that seems to be the solution.

  • JasperJasper

    Team Member

    I'm glad to hear that you were able to get this fixed by changing the time on your Mac! Please let us know if you have any other questions.

  • Hey Jasper;

    Ive got a similar issue happening again. This time with ios 8.1 running 5.1 on the phone. My mac has 1pass 4.4.3 on it. I've checked that the times are the same on my phone and mac like before. Oddly my ipad running ios 8.0 and 1pass 4.5.3 is working fine. Any suggestions for the iphone?

  • MrRooniMrRooni

    Team Member

    Good morning @cmelious. Sorry for the trouble you're having Wi-Fi syncing 1Password 5.1 to 1Password 4.4.3. We did test this scenario before shipping 1Password 5, so we know it's possible, we just need to figure out the problem you're running into. Can you give me some more specifics on the error that you're seeing on your iPhone?

  • There isn't an error, the computer simply does not show up in the wifi sync on the iphone, yet it does show up for the ipad.

  • MeganMegan

    Team Member

    Hi @cmelious,

    By any chance does your computer have a longer name? We've seen some instances where computers with longer names are not showing up on the list of available servers. We're working on getting this fixed, but if you do have a longer name for your computer, changing it to something short should help in the meantime.

  • Hi Megan;

    I just ran the update to 10.9.5 on my mac and everything magically started working again. All devices are syncing properly for now. Thank you for the help.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @cmelious, thank you for letting us know! I'm happy to hear it's working again for you after the OS update. :smiley:

  • Drew...1PW works fine on my MBP and iPad Air 2. I'm in the process of setting-up a new iPhone 6+. Everything looks correct, but I keep getting this message when I attempt to Sync via Wi-Fi: "Sync Problem Error Domain=NSPOSIXEERRORDOMAIN Code 61 The operation couldn't be completed. Connection Refused."

    On my MBP I'm running OS X 10.10 and 1PW 5.0.2 (502006).

    On my iPhone 6+ I'm running iOS 8.1 and 1PW 5.1.1 (501107)

    I sent a diagnostic report from my iPhone 6+ to 1PW Support.


  • Drew...Disregard my earlier post. After doing a complete shutdown of my iPhone, my MBP was mysteriously and automatically renamed and the Wi-Fi Sync was accomplished perfectly.

    Thanks for being available for "we hackers!" :)


  • MikeTMikeT Agile Samurai

    Team Member


    I'm glad you got it working. It is in line with issues we've seen from Yosemite and iOS 8. Hopefully, future updates will resolve them for good.

This discussion has been closed.