PIN Lock w/ Lollipop 4.2b6 (20141219)

Anyone else having this app revert to requiring the master password after a period of time (I can't determine what the specific amount of time is though) ..

On Android 4.4 if I set the PIN lock, it would work until I force closed the app/service or rebooted the phone. Now with Lollipop, that's not working. Not sure if it's an Android 5.0 thing or a 1Password 4.2 thing, but it's clearly not working as intended.

Comments

  • On Android 4.4 if I set the PIN lock, it would work until I force closed the app/service or rebooted the phone.

    That sounds right.

    Now with Lollipop, that's not working.

    What precisely is it now doing?

  • It's asking for the master password...

    At some point, the app is either crashing or it's forgetting that I have it set to PIN lock.

  • I should add -- This issue is persisting after upgrading to 4.2B6. I know in another thread it was mentioned that the "Exiting 1Password" bug was resolved in B6, but I'm at the very least still getting crashes.

  • ok, so when it "forgets the PIN lock setting", if you enter your master password and then look at the Security settings, is the PIN code option still set or has the setting actually been turned off?

  • Yes, the PIN Code setting is set as I had it originally.

  • ok, it does sound like a bug. @mverde, @saad, all your's. :)

    Oh, @macewank, providing details of your device might them sort it.

  • mverdemverde

    Team Member

    @macewank While it's possible that this is a bug with the 1Password beta, there is also currently a known memory leak in Android 5.0.1 that is causing some problems. Because this memory leak means that the device runs out of available memory much faster, it means that 1Password is much more likely to be terminated while running in the background. Any time 1Password is terminated, you will be required to enter your master password on the next launch. Could you tell me which version of Lollipop are you running?

  • @mverde 5.0.1 on a Nexus 6 and a Nexus 9 .. that could very well be the case w/ the system terminating the process! Let's see what happens when they get around to 5.0.2

  • periperi

    Team Member

    Thanks for the update, @macewank‌. Please let us know if the problem persists after the next update. :)

  • I suppose one way to bypass the problem (at the expense of security) is to disable "Lock on exit" and "Automatically lock: Never".

  • saadsaad

    Team Member

    @Sinsear If 1Password is terminated from the background, you will need to enter the master password even if "Lock on Exit" is disabled.

This discussion has been closed.