1Password Pro: iPad, iPhone, MacBook sync, but a record doesn't update on iPad

deslockdeslock Junior Member
edited December 1969 in iOS
Order of events:

1. I updated a record on my iPhone.

2. I synced my iPad and MacBook (running OSX 10.6) computer (which hadn't been synced with the iPhone in a few days).

3. I synced my iPhone and MacBook.

4. I synced my iPad and MacBook again.

The record updated in step 1 is correct on my iPhone and MacBook, but not on my iPad. I repeated step 4 a few times, but it still doesn't work.

I checked the sync history on the iPad. For the logs of every sync, there are a couple lines (with the same timestamp, if that's relevant):

Sending "record name from step 1" [LONG ID STRING]
Scheduled to send 1/1 updates

Otherwise, the sync seems to work just fine. Any thoughts?

Thanks!

Comments

  • jxpx777jxpx777 Code Wrangler 1Password Alumni
    edited December 1969
    Hi, deslock, and welcome to the forums. I'm sorry for the trouble. I have heard this reported before iPad was released from a user who was synching an iPhone and iPod touch. I think that there is possibly a flaw in the logic that decides if an entry should be synched to the device. We'll review the sync code and make any adjustments that are necessary. Naturally now that these touch devices are starting to proliferate, this could become a much more serious problem.

    For now, one thing to check is if the same sync problem happens when you make a change to the entry on 1Password for Mac. Does the update get pushed to both updates properly? If so, please try to make your changes on the Mac side until we are able to resolve this issue.
  • deslockdeslock Junior Member
    edited December 1969
    Thanks for the quick reply. Tonight was the first time I was able to sync since posting here last week; doing what you suggested worked fine.

    I didn't notice that there was an update to 1password yesterday until after I synced so I don't know if that addressed the issue, but no worries... the next time I make changes on my iPhone or iPad, I'll double-check that they carry over.
  • NikNik 1Password Alumni
    edited December 1969
    Thanks for the update, deslock.
  • j!e!t!s!j!e!t!s! Junior Member
    edited December 1969
    I am also having the same issue that deslock is having. Is there any update or ETA on a fix?
  • tawongtawong Member
    edited December 1969
    I also have the same issue.
    -I updated credit card info on iPad
    -Sync to my Mac and everything got updated
    -Sync to my iPhone and it does NOT update on iPhone

    Tried a few times but still the same.

    Another problem.
    -Created a new login on iPhone
    -Sync to Mac is ok.
    -Delete the same item on Mac
    -Sync to iPhone but sync does NOT remove the item on iPhone
    -so I deleted the login on Mac and iPhone manually
    -Next time I sync I kept getting this message for sync conflict

    I don't have screenshot but the message shows that I have one deleted item in Trash but does not exist on iPhone, but I already delete the same item on my Mac & iPhone and emptied the trash. The message kept popping up everything I sync. There is buttons for Skip the item or Sync. I picked either one and the same message kept showing.
  • NikNik 1Password Alumni
    edited December 1969
    Thanks for the additional information. We have reproduced this issue and reported it to our developers, but a fix is not yet available. Your patience is appreciated.
  • j!e!t!s!j!e!t!s! Junior Member
    edited December 1969
    is there any fix yet for this issue?
  • MartySMartyS AgileBits Customer Care (retired)
    edited December 1969
    j!e!t!s! wrote:
    is there any fix yet for this issue?


    I'm afraid not. One workaround would be to have 1Password Mac force a full sync to the mobile device via the "Replace information on this iPhone" checkbox on the device's SYNC window. And yes, we know that for an iPad it still says "... iPhone". :)
  • LRogersLRogers
    edited December 2010
    I've been using 1password for 5 or 6 months without issues. Tonight after adding 3 new logins i synced from my MacPro to my iPad and iPhone. Several issues are now occurring:

    1) Running Safari 5.0.3 and 1password 3.5.3 and OS X 10.6.5 Safari crashes each time I add a login to 1password at the moment I hit the 1password "save" button in Safari. It adds the site to 1password but not the login data.

    2) Running 4.2.1 on my iPad I had to force quit 1password and then restart it before it would sync. I'm doing this over wi-fi with both devices on the same network. 1password on my mac was saying that the I pad wasn't on the wi-fi network when it was. After restarting of 1password on the iPad then it was seen and the sync was successful.

    3) The same was true on my iPhone 4 running 4.2.1. I had to force quit 1password and restart it before it was seen in 1password on my mac as been available on the wi-fi network and therefore sync-able.

    4) The iPhone sync was reported as being successful BUT the new logins were not in 1password on the iphone. After waiting an hour and syncing again the data is there. Quite troubling!

    I love your product and I understand bugs can creep in.

    PS On the Mac there is a count of "xx items by Title" showing for example the number of logins in a vault. It would be nice to have this on my iPad and iPhone also as an easy check of things.
  • MikeTMikeT Agile Samurai

    Team Member
    Hi LRoger, welcome to the forums.

    I was not able to reproduce the crashing issue with 1Password in Safari. You may need to reinstall the extensions to resolve the crash.

    1) Open 1Password, unlock and then select Preferences in 1Password's Main Menu or press "Command + ,"
    2) Go to the Browsers section and press "Remove all Extensions"
    3) Go to Help > Troubleshooting > Reset Folder Permissions
    4) Go back to the Browsers window and press "Install all extensions"
    5) See if you can save without it crashing now.

    As for the Wi-Fi Sync, did you restart 1Password for Mac first before restarting 1Password on your iOS devices? I'm wondering if you may have a damaged 1Password installation, which could explain the crashing issue in Safari and now the Wi-Fi sync.

    If the first instruction does not resolve the crash issues, please reinstall 1Password.

    1. Download 1Password from our web site:
    http://agilewebsolutions.com/downloads
    Click on the "Download Now" button under "1Password 3"
    2. Quit your web browser and 1Password, if it's running
    3. Open your Applications folder and drag 1Password to the Trash
    4. Install the new copy of 1Password you just downloaded
    5. Run 1Password and then your web browser

    Your information is stored in a data file separate from the application, so it will not be harmed by this procedure.

    Please let me know how it turns out. If it does not fix the problem, please contact us at [email protected] with your Diagnostic Report. Please do not attach or upload your report here, only via your email to us. You can generate the report from 1Password on your Mac by clicking the Help > Troubleshooting > Diagnostics Report... menu item and then sending the report to us at [email protected] using your email application.

    Please include a link to this thread in your email message so that we can 'connect the dots'.
This discussion has been closed.