Extension Database Not Available

I’m having the same problem a lot of other users have had with the Safari extension not working. I have uninstalled and reinstalled the extension (3.9.20) several times, rebooting my Mac inbetween. I’m running OS X Yosemite v 10.10.2. Can anyone help me get this working again? I miss being able to auto-login.

Comments

  • If this helps, I had the same problem before upgrading OS to Yosemite, which reflects the same problem other (and older) posters have had with the same error, 'Extension Database Not Available'. The only problem with the other posts is that the resolution isn't detailed, and thus 'closed' as if Agilebits resolved the issue with the poster. If this is how we're supposed to find answers to known issues regarding 1Password problems, I implore the tech support staff to provide the instructions that were given to the user (minus screenshots, system reports) to fix the issue. It would be nice if Agilebits provided a support system that isn't blog-based, but rather, addressed professionally on a case-by-case basis using tickets. I hate that I have to bookmark my post and check on it to only find 'X' people 'viewed' my question and '0' have replied.

  • Hi @csummerlot,

    The first thing we need to do is determine what version of 1Password you are running? If you're running 1Password 4 or 5 then that extension is not the one you are wanting to have installed. If you are indeed running the older version of 1Password 3 that changes matters.

    So if you're running 1Password 4 or 5. You'd first want to remove the old extension and download the correct version from this page, https://agilebits.com/onepassword/extensions

    If you are indeed running 1Password 3 for Mac let us know.

  • Yes, I am running 1Password 4. I went to the URL you gave me, downloaded the extension, but NOW I get the following error: "There is no application set to open the URL onepassword4-extension://activate/Safari" at the finalization of the install. And when I click the 1Password icon next to the address bar, I get the error again.

  • Additionally, I thought I found the fix for the new problem here: https://discussions.agilebits.com/discussion/24512/safari-extension-installation-trouble
    But after trying @krmoore42's instructions, it didn't work for me. In the final step, it's still asking me what app I want to use to open the URL "onepassword4-extension://activate/Safari"

  • Drew_AGDrew_AG 1Password Alumni

    Hi @csummerlot,

    You mentioned your Mac is running OS X 10.10.2 (Yosemite), but you also said you're using 1Password 4 on your Mac. In that case, you should first update that to 1Password 5. If you're using the Agile Web Store version of 1Password for Mac, open the main 1Password app and go to the menu for 1Password > Check for Updates. If you're using the Mac App Store version, open the Mac App Store and check the Updates section.

    Once you've installed 1Password 5, please open it and go to the menu for 1Password > Install Browser Extensions (that should open the extension site in Safari). Click the big green Install button, and follow the steps there to install the extension.

    Please also delete (or at least disable) the 1Password 3 extension in Safari. You can do that from Safari > Preferences > Extensions.

    Are you able to install the newer extension? Let us know how it goes, and if it's still a problem, we'll take it from there. Thanks!

  • I know I first got the app through the App Store but I think I upgraded since then via Agilebit's site. Regardless, there was no update for it in the App Store and when I go through 1Password > Check for Updates, I get the message "You are running the latest version....". So I went to check the version again so I could re-send that info to you and saw a "Upgrade Now' button, so I clicked that. It took me to the proper page and all, but wants $24.99 to upgrade and I wasn't wanting to spend more money in order to fix this problem. Do you have any other suggestions?

  • Drew_AGDrew_AG 1Password Alumni

    Hi @csummerlot,

    It sounds like you currently have the web store version of 1Password installed on your Mac. Can you please check the exact version number? In the main 1Password app, go to the menu for 1Password > About 1Password. What is the exact version shown in that window?

  • Version 3.8.22 (build 32010)

  • littlebobbytableslittlebobbytables

    Team Member
    edited February 2015

    Hi @csummerlot,

    I've moved your post to the 1Password 3 for Mac forums to ensure that if required, more experienced people with 1Password 3 see it.

    So we've now established you're running 1Password 3 we can look at the troubleshooting steps more specific to it (which are very different from those in 1Password 4/5).

    We have one troubleshooting tip that may be pertinent, Data Not Available Error

    I would recommend checking that link out and seeing if it helps. Please note that the section on private browsing may or may not still be applicable so it's worth reading and ensuring it doesn't. As you're running Yosemite I don't believe you can turn it off and on but maybe you've been using a private window?

    If that doesn't I would also suggest checking out a sticky in this particular forum, "Problem with database" in v3 extension in Safari on OS X Mavericks

    Let us know if that helps at all :smile:

This discussion has been closed.