1P won't install in browsers if not in Applications Folder

Bug
The 1P button did not appear in Firefox, despite repeatedly asking 1Password to do it, and receiving no notice of failure.

After investigation, I have figured out it was because Firefox was not directly in the Applications folder, but in a subfolder instead. When installing extensions, 1Password just remains totally silent as to which browsers are actually found, this is not very user-friendly!

Under Mac OS X, it is not a requirement for an application to be directly in the Applications folder, therefore this qualifies as a bug.

It is my own practice to put all "extra" applications in subfolders of the Applications folder, just like the "Utilities" folder.
This way I can separate the applications that I have bought, from the Freeware, and from the default applications that come from Mac OS installation.
Additionally, if an application come with a PDF manual, or with some "Extra stuff", I group all this in yet another sub-folder to keep it all organized. It's all natural to do it like that.
Even 1Password itself is located in a subfolder on my Mac. It works fine with no complaint, except that it cannot find Firefox!

So… I suggest adding a manual "locate" function:
The Advanced box could list the browsers ACTUALLY found instead of showing all compatible browsers in existence (user may be confused with those unknown browsers, wondering whether they exist on his/her mac).
Then add a button to let the user find more browsers manually if necessary.
Finally, a user feedback to signal success after installation on each browser would be nice too!

Incidentally, I think that 1Password could recursively extend the search to sub-folders of Applications, that seems so natural… In my mind, a file I place in a sub-folder of the Applications folder is technically in the Applications folder as well, just like a book placed in a drawer in my house is indeed in my house. That's the way the folder metaphor works...

Comments

  • khadkhad Social Choreographer

    Team Member
    edited January 2011
    Thanks for the feedback, evol. I'm sorry that you had this problem.

    I was not able to reproduce the problem with extensions not being loaded when browser application bundles are located in a subfolder of your Applications folder. I have Firefox 3 and Firefox 4 in a subfolder of my Applications folder called "Browsers." I am able to perform "Remove All Extensions" and "Install All Extensions" and verify the removal and installation of the extensions at each step. The extensions are actually stored in your Application Support folder which is independent of the actual application bundle's location.

    Please quit your web browser(s) and then:

    1. Open 1Password
    2. Open 1Password's Preferences to the Browsers pane
    3. Click the "Remove All Extensions" button
    4. Click the "Install All Extensions" button

    The reason we show browsers which are not installed is that some folks install 1Password first thing after getting a new Mac or a fresh OS X install. This was you can install all the extensions in the Application Support folder and they will be waiting for you when/if you install the additional browser(s).

    A confirmation of extension installation is, unfortunately, not a simple task. The "Install All Extensions" button essentially just copies those files which will produce an error if there is a problem with the copying, but otherwise, factors affecting your usage of the browser extensions often lies outside of 1Password itself. So, a "successful" browser extension installation from within 1Password may still fail to work if there is a problem elsewhere on your system. :-(

    For this reason, it would not be very helpful to say whether or not the extension installation was "successful" or not. It may have been from 1Password's perspective, but the browser itself may have configuration problems.

    I hope that helps. Please let me know.
This discussion has been closed.