Must choose Login item from extension instead of it being chosen automatically [Resolved]

Hello all,
Recently (not sure when exactly) I started getting it that my logins have stopped filling in when I use the keyboard short cut or mini. It knows I have a password for that site and give it as an option, but then I have to select the option instead of it auto picking.

For example in my company we have many sites that use our domain that I log into. So I have X.mycompany.com with username/password details, and those same details are used for Y.mycompany.com and Z.mycompany.com, when I got to one of these sites I use CMD+\ instead of it filling in the details I have to select an option. This is due to A.mycompany.com having different login details, but I have all the URLs for the first login in the 1p details, so I have one 1p entry called mail.mycompany.com and under that I have listed 'website' the correct websites.

Any ideas what could be causing this, I'm sure it used to recognize the correct site and fill in the details?

My explanation might not be the clearest, any questions please ask away.

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @charliwest,

    I might be a little confused, so to make sure if I understand, it sounds like you have two different Login items:

    • One Login contains the URLs for X.mycompany.com, Y.mycompany.com, and Z.mycompany.com, as well as a username & password for those sites.
    • The other Login contains the URL for A.mycompany.com, as well as a different username & password.

    Is that correct? If so, when you go to one of the X/Y/Z sites and invoke the 1Password extension, does it show both of those Login items and you need to choose the correct one?

    Or if I misunderstood, can you please elaborate on your setup and exactly what you see when you go to a site and call up the 1Password extension? Thanks!

  • Hello,

    I have had a look around and I see similar but I don't think the same issue as this. When I use the shortcut cmd \ to autofill sites it gives me lots of options, I have filled in the website details against that log in, but every time I use the short cut it gives me lots of options related to as they are all mycompany.com, but the www bit and ports are often different. How can I get it to just autofill for the correct URL?

    For example I have a log in for www.mycompany.com, but also a log in for webmail.mycompany.com and yet another for calendar.mycompany.com:8443 but they are all the same username and password, so I want all to autofill when I click cmd .

    Thanks

    1Password 5.4 BETA-7
    1Password Beta 4.4.0.5 extension
    OS X 10.10.3
    Although has been happening for a while on various versions of all of the above.

  • Hmmm I just posted this question again forgetting I already did it, then noticed my notifications that you responded to this @Drew_AG and now I can't delete my new post.

    Anyway, thanks for getting back to me, sorry I didn't notice.

    You are correct in your two statements I believe.

    when you go to one of the X/Y/Z sites and invoke the 1Password extension, does it show both of those Login items and you need to choose the correct one?

    Yes thats right, it gives me options for A and X/Y/Z (as X, Y and Z are all the exact same username and password they are lumped together in one entry in 1Password, with different websites against them)

    Is that clear? I can send screen shots, although would prefer them not to be public.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @charliwest,

    No problem! I've merged your other message into this thread, and moved it to our Saving and Filling in Browsers forum.

    It sounds like this is related to the Lenient URL matching setting in 1Password. Lenient URL matching determines how picky the browser extensions are about matching your saved Logins to the current URL. When enabled, 1Password will only look at the main domain (mycompany.com) not the subdomain (X.mycompany.com, A.mycompany.com). You can check that setting with these steps:

    • Open the main 1Password app.
    • Go to the menu for 1Password > Preferences.
    • Select the Browser tab.
    • Disable the Lenient URL matching option.

    If you needed to disable Lenient URL matching, try logging into one of your X/Y/Z sites again. Does it work as expected? If not, what happens now?

  • That was exactly it, thank you!

  • MeganMegan

    Team Member

    Hi @charliwest ,

    I'm so glad that Drew was able to get things sorted out for you - thanks for letting us know! As an Agile employee, I end up with a host of Logins for various 'agilebits.com' URLs, and precise domain matching (which is what you get when you disable the 'Lenient URL Matching') is so helpful when signing in to websites.

    Since this particular issue is resolved, I'll close this thread, but if you have any further questions or concerns, please don't hesitate to open a new thread, or email us directly at [email protected] - we're here for you. :)

This discussion has been closed.